View Issue Details

IDProjectCategoryLast Update
0018760Starward Rogue[All Projects] SuggestionJul 9, 2017 7:00 pm
ReporterlogorougeAssigned To 
Severityminor 
Status resolvedResolutionopen 
Product Version1.015 
Fixed in Version1.506 (The Perk Overhaul) 
Summary0018760: Immunity to spikes
DescriptionA new levelup perk (or item?) to gain immunity against spike damages. Not all the spiky rooms have teleport shortcuts and the ability to freely move in those rooms would make it an interesting option I think.
TagsNo tags attached.

Activities

ptarth

Feb 28, 2016 1:46 am

developer   ~0045286

There is an item or ability that does grant this. I don't recall the name of it offhand.

logorouge

Feb 28, 2016 3:26 am

reporter   ~0045287

Risky Assassin does grant a few seconds of immunity at the start of each room. If another item exist, I've never seen it ingame or while searching inside the game's files.

I would still suggest adding a levelup equivalent and if there is an item, I think its droprate should be increased dramatically.

ptarth

Mar 1, 2016 6:03 pm

developer   ~0045309

Okay. I looked into this more.
You are correct.

Risky Assassin makes you immune to Hazard and Explosive damage. However, the damage caused by Caltrops is damage_per_second_from_touching. Damage from touching turns into melee damage, which turns into Ballistic damage in shots, but is typeless damage in ships.

I see two immediate solutions.
1. Add a melee_damage_type attribute.
2. Change the caltrop damage to a undestroyable invisible overlapping shot that causes obstacle damage.
3. Should caltrops be destroyable?

logorouge

Mar 2, 2016 1:12 am

reporter   ~0045321

I'm guessing the Hazard immunity is what protects (temporarily) Risky Assassin from caltrops, but "Hazard" probably includes a bunch of other things so it can't really be used as is. Would adding a new damage type be troublesome at this point?

On the other hand, for destroyable caltrops, my understanding is that caltrops are considered a type of floor. Can they really be replaced by other tiles on the fly?

ptarth

Mar 2, 2016 2:41 am

developer   ~0045337

Hazard immunity just protects from Hazard damage. The only entities that use Hazard damage are lasers and turrets. Mines are explosive damage.

Caltrops literally have no damage type, damage from them happens as a collision with enemy entity.

Caltrops are actually entities (like ships) that are immune to damage and their hitbox does not collide with shots. They could be converted into damageable entities. However, that would also lead to players just shooting through the fields (literally).

logorouge

Apr 19, 2017 5:14 pm

reporter   ~0046062

With the new Trapmaster perk, I think this one can be marked as "Resolved". :)

Pepisolo

Jul 9, 2017 7:00 pm

developer   ~0046390

Got it, cheers. :)

Issue History

Date Modified Username Field Change
Feb 27, 2016 9:27 pm logorouge New Issue
Feb 28, 2016 1:46 am ptarth Note Added: 0045286
Feb 28, 2016 3:26 am logorouge Note Added: 0045287
Mar 1, 2016 6:03 pm ptarth Note Added: 0045309
Mar 2, 2016 1:12 am logorouge Note Added: 0045321
Mar 2, 2016 2:41 am ptarth Note Added: 0045337
Apr 19, 2017 5:14 pm logorouge Note Added: 0046062
Jul 9, 2017 7:00 pm Pepisolo Status new => resolved
Jul 9, 2017 7:00 pm Pepisolo Fixed in Version => 1.506 (The Perk Overhaul)
Jul 9, 2017 7:00 pm Pepisolo Note Added: 0046390