View Issue Details

IDProjectCategoryLast Update
0017686Stars Beyond Reach[All Projects] GUIOct 7, 2015 1:14 pm
ReporterdfinlayAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.916 (Money-Grubbing Citizens) 
Fixed in Version0.919 
Summary0017686: Income indicator goes down when spending crowns
DescriptionThe display above your crowns where your income is supposed to be displayed seems to be displaying the difference between your current money and the money from the previous turn. As such, if you spent crowns this turn, it doesn't reflect your income and spending more money than you made causes it to go negative. It should instead display your income, ie. what gain you should expect to get next turn.
TagsNo tags attached.

Activities

Cinth

Oct 4, 2015 8:58 pm

manager   ~0043365

It displays the net change in the turn to turn. Spending a lot does cause a negative in your turn to turn.

dfinlay

Oct 4, 2015 11:09 pm

reporter   ~0043377

I understand that. It is just that that isn't what I (and I would think most other people, though I could be wrong) would expect it to do. Evidence that I'm not the only one who thinks this is odd is on this thread: https://www.arcengames.com/forums/index.php/topic,18027.0.html
The number people are most likely going to want to know is "How much can I expect to make over the next few turns" and this doesn't present that.

ptarth

Oct 4, 2015 11:10 pm

reporter   ~0043378

I'm not a big fan of the change myself.

Rythe

Oct 4, 2015 11:37 pm

reporter   ~0043379

Last edited: Oct 4, 2015 11:38 pm

View 2 revisions

I think I'm going to side with dfinlay and ptarth on this one. I'd prefer just to see my forecasted gross income for the next turn above current crowns.

Net crowns for the turn is kinda superfluous info given the nature of the game. What matters most is how many crowns I currently have and how many more I will get going into next turn.

Cinth

Oct 4, 2015 11:57 pm

manager   ~0043380

Gross can not tell you if your per turn pop maintenance is going to cost you more than you make (net negative). If that happens when you are low on crowns you can effectively game over yourself.

Rythe

Oct 5, 2015 1:14 am

reporter   ~0043382

Oh right, the population cost change. Hmmm, that does put a wrinkle in it.

gnosis

Oct 5, 2015 9:10 am

reporter   ~0043387

subtract the pop cost, but don't subtract anything else during the turn.

ptarth

Oct 5, 2015 10:17 am

reporter   ~0043390

I don't want a projection for next turn. I want how much I got this turn.

gnosis

Oct 5, 2015 10:45 am

reporter   ~0043394

ok, but what should be displayed on the top? most people expect next turn projection. perhaps an option should be added or an extra number somewhere.

ptarth

Oct 5, 2015 10:50 am

reporter   ~0043395

It's never been the next turn projection. It has always been the this turn projection. I can't actually think of a game that uses a next turn projection. Next turn projections would require knowing: new building completions, power status, worker status, and so forth.

gnosis

Oct 5, 2015 11:05 am

reporter   ~0043397

next turn projection without the new buildings I will get

dfinlay

Oct 5, 2015 6:07 pm

reporter   ~0043431

Most games don't include one-time costs, though. If you buy a builing outright in Civilization, for example, it doesn't decrease the income value. Nor would it doing seem to be helpful for the issue Cinth mentioned. It really should just be ongoing income minus ongoing costs.

gnosis

Oct 5, 2015 6:33 pm

reporter   ~0043433

Barring that, we would need a detailed budget screen.

keith.lamothe

Oct 7, 2015 1:14 pm

administrator   ~0043499

For 0.919:

* The recent change to make the crown income indicator based off actual accounting records (as opposed to current production and consumption of crowns) has been amended to ignore accounting records for expenses directly caused by the player (placing buildings, etc).

Thanks :)

Issue History

Date Modified Username Field Change
Oct 4, 2015 8:53 pm dfinlay New Issue
Oct 4, 2015 8:58 pm Cinth Note Added: 0043365
Oct 4, 2015 11:09 pm dfinlay Note Added: 0043377
Oct 4, 2015 11:10 pm ptarth Note Added: 0043378
Oct 4, 2015 11:37 pm Rythe Note Added: 0043379
Oct 4, 2015 11:38 pm Rythe Note Edited: 0043379 View Revisions
Oct 4, 2015 11:57 pm Cinth Note Added: 0043380
Oct 5, 2015 1:14 am Rythe Note Added: 0043382
Oct 5, 2015 9:10 am gnosis Note Added: 0043387
Oct 5, 2015 10:17 am ptarth Note Added: 0043390
Oct 5, 2015 10:45 am gnosis Note Added: 0043394
Oct 5, 2015 10:50 am ptarth Note Added: 0043395
Oct 5, 2015 11:05 am gnosis Note Added: 0043397
Oct 5, 2015 6:07 pm dfinlay Note Added: 0043431
Oct 5, 2015 6:33 pm gnosis Note Added: 0043433
Oct 6, 2015 9:36 am x4000Bughunter Assigned To => keith.lamothe
Oct 6, 2015 9:36 am x4000Bughunter Status new => assigned
Oct 7, 2015 1:14 pm keith.lamothe Note Added: 0043499
Oct 7, 2015 1:14 pm keith.lamothe Status assigned => resolved
Oct 7, 2015 1:14 pm keith.lamothe Fixed in Version => 0.919
Oct 7, 2015 1:14 pm keith.lamothe Resolution open => fixed