View Issue Details

IDProjectCategoryLast Update
0016075The Last Federation[All Projects] Crash/ExceptionDec 31, 2014 2:17 pm
ReporterVanreisAssigned Tox4000Bughunter 
Severityblock 
Status resolvedResolutionfixed 
Product Version2.008 (Cumulative Hotfixes) 
Fixed in Version2.011 
Summary0016075: Stuck on first screen
DescriptionI have nearly identical problem as this one -> http://arcengames.com/mantisbt/view.php?id=15528

I launch the game and then only see black screen and editable space with default name (Hydral) in it. If i click around the screen I sometimes hear a bleep.
Similary to that older issue the process "hangs" in Task Manager for at least few minutes. It also somehow blocks my internet while it "hangs" (my network still works but nothing loads and Steam goes offline.
I've tried using Arcen Updater and it behaves the same (black screen, hanging etc). When I left it going for few minutes it loaded version and program name.

I've edited my settings file to stop automatic update, added the game to "trusted" lists in my antivirus and even disabled it, nothing helped.

Also, I'm not really sure about the version I have. It's on Steam so I assumed I have the newest one but then again updater doesn't work so I'm not sure.
TagsNo tags attached.
Internal WeightNew

Activities

x4000Bughunter

Dec 23, 2014 12:44 pm

administrator   ~0039780

Sorry to hear about your troubles here.

If you're on Steam, you do have the latest version. You can use the verify local file cache command in steam to make sure that all the files got downloaded properly, though -- sometimes Steam misses a file or two, randomly.

As for the updater, note that it's just the unpacker portion. The updater itself is launched from within the game when there is an update, not directly from the file system. So that's likely working fine, although it's not verifiably fine unless you had launched it from in-game when there's an update (which is almost never possible on steam, because steam downloads the updates preemptively, heh).

As to the core issue, what antivirus are you using? If it's AVAST, that's one that just seems to hate a lot of unity games: http://www.arcengames.com/forums/index.php/topic,15352.0.html

Adding exceptions or even disabling AVAST tends not to help -- odd as that is. Uninstalling tends to be the only solution, unless one of the other workarounds works.

One common workaround when a game is being killed by antivirus is to move the game folder out of your Program Files folder and into some other location. I have no clue why that makes a difference to the antivirus, but it can. There are a variety of things that people have done to help with this sort of problem, though, depending on the program causing the issue. Most of those potential solutions are identical for our other games, and for other Unity 3D games like Kerbal Space Program and similar.

It's also possible that steam just simply did a bad download and that verifying the local file cache will fix it right up. That's rare, but it does happen from time to time.

Hope that helps!

Vanreis

Dec 23, 2014 2:07 pm

reporter   ~0039781

I do not use Avast because of past conflicts with some other game.
I've tried your suggestions, moved the game to D:\, reistalled it, verified cache and none of that works. I still do not get any error message nor crash, it just opens to black screen with editable slot. Also, as mentioned above, every time I quit the game it blocks my internet for few minutes, no idea why.

x4000Bughunter

Dec 23, 2014 2:15 pm

administrator   ~0039782

Hmm. The editable slot is asking you for a profile name, so there is that. Not sure why it's just sticking on that one screen for you and having no other visuals. It should have some buttons on there for OK and cancel. If you click down underneath it at the right-hand side of the textbox, then you might be able to get past that screen and then see what happens. I can't recall if the enter key works here, but I don't think so.

You might want to try running this in windowed mode and see if that does any different for you.

As to the internet connection thing, I really have no idea on that. No software should have the power to do that to your internet connection, and with the auto-updates turned off here this doesn't even use your internet connection. So it sounds like some sort of network driver card issue, I'm not sure.

Vanreis

Dec 23, 2014 2:34 pm

reporter   ~0039783

I've tried clicking blindly and the only effect I've got was a bleep when cursor was near the text. Same thing in windowed mode. Enter does not work.

x4000Bughunter

Dec 23, 2014 2:51 pm

administrator   ~0039784

Super strange. I've uploaded an attached file to this ticket called Hydral.profile. If you put that in your RuntimeData/Save/ folder, then it should stop asking you about a profile and at least get you past that screen. Although it may ask you to select a profile, not sure, in which case you'd select that one.

Vanreis

Dec 23, 2014 3:29 pm

reporter   ~0039785

Sorry, I can't find the file on the screen. I'm probably blind but where exactly is it?

x4000Bughunter

Dec 23, 2014 3:39 pm

administrator  

Hydral.profile (63 bytes)

x4000Bughunter

Dec 23, 2014 3:40 pm

administrator   ~0039786

Ack! It really helps if I hit the upload button properly. Sorry about that, it's there now.

Vanreis

Dec 23, 2014 4:02 pm

reporter   ~0039787

Last edited: Dec 23, 2014 4:12 pm

View 2 revisions

No problem, happens to everyone.

Okay, we are getting somewhere! At first it was just pure black screen with nothing on it, then it loaded game, developer and dlc logo and moments afterwards small text in the middle "Loading items from disk". At first it counted down but then it got stuck on 297 and right before I quit it it changed to 291. I think it might actually load but extremaly slowly for some reason. Oh, it also shows the game version as 2.009. Weird considering 2.008 was just released.

x4000Bughunter

Dec 23, 2014 9:43 pm

administrator   ~0039788

Hmm, that's really odd indeed. We did release 2.009 lately, though. It sounds like the game is loading assets super slowly for some reason. You might look into the runtimedata folder in the game folder and see if there are any errors or other logs. Inside LastFederation_Data there is also an output.log file that might have some info.

Beyond that, the question is why the www calls to load stuff off disk is happening so slowly. I'm not sure if there is something with some of your software or hardware that is clashing with this particular version of the unity engine. You could try loading up the demo of one of our other games and see if they have the same problem; I would expect so if this is a conflict with the engine and your system for some reason.

Vanreis

Dec 24, 2014 9:17 am

reporter  

output_log.txt (5,057 bytes)
Initialize engine version: 4.2.1f4 (4d30acc925c2)
GfxDevice: creating device client; threaded=1
Direct3D:
    Version:  Direct3D 9.0c [nvd3dum.dll 9.18.13.4709]
    Renderer: NVIDIA GeForce GTX 650 Ti BOOST
    Vendor:   NVIDIA
    VRAM:     1989 MB (via DXGI)
    Caps:     Shader=30 DepthRT=1 NativeDepth=1 NativeShadow=1 DF16=0 DF24=0 INTZ=1 RAWZ=0 NULL=1 RESZ=0 SlowINTZ=0
Begin MonoManager ReloadAssembly
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\UnityEngine.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\UnityEngine.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Assembly-CSharp.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Assembly-CSharp.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Lidgren.Network.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Lidgren.Network.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Ionic.Zip.Reduced.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Ionic.Zip.Reduced.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\ExcelLibrary.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\ExcelLibrary.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.CJK.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.CJK.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.MidEast.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.MidEast.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.Other.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.Other.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.Rare.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.Rare.dll into Unity Child Domain
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.West.dll (this message is harmless)
Loading D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\I18N.West.dll into Unity Child Domain
- Completed reload, in  0.082 seconds
<RI> Initializing input.

<RI> Input initialized.

desktop: 1680x1050 59Hz; virtual: 1680x1050 at 0,0
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\Steamworks.NET.dll (this message is harmless)
Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\System.dll (this message is harmless)
Steamworks Init
 
(Filename: C:/BuildAgent/work/cac08d8a5e25d4cb/Runtime/ExportGenerated/StandalonePlayer/UnityEngineDebug.cpp Line: 54)

Steamworks IsRunning: True
 
(Filename: C:/BuildAgent/work/cac08d8a5e25d4cb/Runtime/ExportGenerated/StandalonePlayer/UnityEngineDebug.cpp Line: 54)

graphicsShaderLevel:30
graphicsDeviceID:4546
graphicsDeviceName:NVIDIA GeForce GTX 650 Ti BOOST
graphicsDeviceVendor:NVIDIA
graphicsDeviceVendorID:4318
graphicsDeviceVersion:Direct3D 9.0c [nvd3dum.dll 9.18.13.4709]
graphicsMemorySize:1989
graphicsPixelFillrate:-1
operatingSystem:Windows 7 Service Pack 1 (6.1.7601) 64bit
processorCount:4
processorType:AMD Phenom(tm) II X4 965 Processor
supportsImageEffects:True
supportsRenderTextures:True
supportsShadows:True
supportsVertexPrograms:True
systemMemorySize:8174
 
(Filename: C:/BuildAgent/work/cac08d8a5e25d4cb/Runtime/ExportGenerated/StandalonePlayer/UnityEngineDebug.cpp Line: 54)

Platform assembly: D:\Gry\SteamLibrary\steamapps\common\The Last Federation\LastFederation_Data\Managed\System.Xml.dll (this message is harmless)
output_log.txt (5,057 bytes)

Vanreis

Dec 24, 2014 9:22 am

reporter   ~0039789

I've tried the A Valley Without Wind and BionicDues demos and had the same problem as with The Last Federation so I guess it is a problem with the engine.

I've looked through the output.log file and didn't find anything suspicious so I uploaded it if you want to check yourself.
Also, I've updated my OS but that didn't do anything with my issue.

x4000Bughunter

Dec 24, 2014 10:23 am

administrator   ~0039790

Yeah, everything is looking fine there. Normally I'd try to google around more on this and see what I can find, but it's Christmas Eve and I've got a coughing 4-year old and so on, so I'm a bit out of time for a few days. The engine is unity 3D, so if there are any references around to what might cause slow loading of WWW calls, that would be the main thing to check.

Other ideas would be to disable the music and sound and see if that helps (you can do that in the settings.dat). That's a longshot, but you never know.

Sorry I have to run!

Vanreis

Dec 25, 2014 6:29 am

reporter   ~0039791

First off, I'd like to thank you for helping me despite it being Christmas. I won't die if I can't play so you can ignore me for the next few days, I can wait. I've found some possible solutions to my problem so I'll just take my time trying them all. Merry Christmas!

x4000Bughunter

Dec 30, 2014 10:53 am

administrator   ~0039794

It's absolutely my pleasure, and I hope that things are working out for you and that you also have had a Merry Christmas! And a happy new year -- we'll be officially back in the office on the 5th, but I'm taking care of a few things at the moment to tidy up before I get back. :)

Vanreis

Dec 30, 2014 2:43 pm

reporter   ~0039795

Okay, I know what causes the problem. Like you said, I've googled for slow loading WWW class and found that its commonly caused by multiple network adapters and I have three. I've disabled them all and the game worked flawlessly. Now, I have a different problem though, to play the game I can't have any of them enabled, including the one that's responsible for Internet access. If I could simply disable it and play I would've been okay with that but I can't. I would have to restart my PC every time I wanted to switch it on or off. Since that slow loading is supposedly caused by multiple network adapters and it should work on one then I have a theory - is it possible to have an active adapter that does not show in device manager?

x4000Bughunter

Dec 30, 2014 7:40 pm

administrator   ~0039796

Wow, very strange!

What OS are you on?

Personally I am on Windows 7, and I have 1 physical network adapter, as well as 1 VPN adapter and 3 virtual adapters. In the past I've also had a second physical adapter (wifi) in place as well. So apparently it's not a universal problem when you have multiple adapters, even though that's what causes it in the cases where it does happen.

I wonder if a network card driver or an OS update (all those various patches they do) might fix the issue?

Thanks for your sleuthing on this, that's a really big deal for me because I've never been able to reproduce it, and thus never had any info to really go on directly. I will see if I can create some sort of better version of this on Monday or Tuesday that might work around your problem. That's certainly super annoying, to say the least, and surely there's a better way.

We'll continue to use the WWW class for music for sure, but that is only one file and so a delay in it isn't really a big deal. For the graphics it's where there is a huge lag there. And it might make the update checks more robust if I code those to avoid the WWW class, come to think of it -- I might be able to prevent AVAST from killing the game if I roll my own version, we'll see. I'm honestly not sure why I never thought of this before now, but I don't like reinventing the wheel without a really good reason.

Vanreis

Dec 31, 2014 9:49 am

reporter   ~0039798

I'm also on Windows 7 and have recently updated it while trying to find reason for such weird behaviour. For reason unknown I had disabled automatic updates so I had to download 134 updates. As you can imagine those didn't really help me in this matter. The one active network adapter is also up to date.

x4000Bughunter

Dec 31, 2014 11:58 am

administrator   ~0039799

Okay, thanks for the info -- that at least narrows it down! Well, I'm about 50% of the way through a redo implementation of the WWW class that should not have any such bugs.

x4000Bughunter

Dec 31, 2014 2:17 pm

administrator   ~0039801

All righty! :)

http://arcengames.com/mediawiki/index.php?title=The_Last_Federation_Post-2.0_Release_Notes#Version_2.011

Issue History

Date Modified Username Field Change
Dec 23, 2014 9:40 am Vanreis New Issue
Dec 23, 2014 12:44 pm x4000Bughunter Note Added: 0039780
Dec 23, 2014 12:44 pm x4000Bughunter Assigned To => x4000Bughunter
Dec 23, 2014 12:44 pm x4000Bughunter Status new => feedback
Dec 23, 2014 2:07 pm Vanreis Note Added: 0039781
Dec 23, 2014 2:07 pm Vanreis Status feedback => assigned
Dec 23, 2014 2:15 pm x4000Bughunter Note Added: 0039782
Dec 23, 2014 2:34 pm Vanreis Note Added: 0039783
Dec 23, 2014 2:51 pm x4000Bughunter Note Added: 0039784
Dec 23, 2014 3:29 pm Vanreis Note Added: 0039785
Dec 23, 2014 3:39 pm x4000Bughunter File Added: Hydral.profile
Dec 23, 2014 3:40 pm x4000Bughunter Note Added: 0039786
Dec 23, 2014 4:02 pm Vanreis Note Added: 0039787
Dec 23, 2014 4:12 pm Vanreis Note Edited: 0039787 View Revisions
Dec 23, 2014 9:43 pm x4000Bughunter Note Added: 0039788
Dec 24, 2014 9:17 am Vanreis File Added: output_log.txt
Dec 24, 2014 9:22 am Vanreis Note Added: 0039789
Dec 24, 2014 10:23 am x4000Bughunter Note Added: 0039790
Dec 25, 2014 6:29 am Vanreis Note Added: 0039791
Dec 30, 2014 10:53 am x4000Bughunter Note Added: 0039794
Dec 30, 2014 2:43 pm Vanreis Note Added: 0039795
Dec 30, 2014 7:40 pm x4000Bughunter Note Added: 0039796
Dec 31, 2014 9:49 am Vanreis Note Added: 0039798
Dec 31, 2014 11:58 am x4000Bughunter Note Added: 0039799
Dec 31, 2014 2:17 pm x4000Bughunter Internal Weight => New
Dec 31, 2014 2:17 pm x4000Bughunter Note Added: 0039801
Dec 31, 2014 2:17 pm x4000Bughunter Status assigned => resolved
Dec 31, 2014 2:17 pm x4000Bughunter Fixed in Version => 2.011
Dec 31, 2014 2:17 pm x4000Bughunter Resolution open => fixed