View Issue Details

IDProjectCategoryLast Update
0015922AI War[All Projects] Bug - GameplayOct 6, 2014 8:12 pm
ReporterFleet UnityAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version8.014 
Fixed in Version8.015 
Summary0015922: Ship Icons drawing on top of each other in diffrent zoom modes
DescriptionWhen you are in far zoom the time when the ship icons appear and if the ships icons overlap they flicker as it is trying to draw both of them on top of each other so you see it transparent, this is the best way to describe it. It may have something to do with the removing of the sort ship textures option I never used it but it almost like it is “on” now if I am not mistaken that’s what could happen if you used it. I know this never happen before this option was removed. Not sure if that was the cause or not. Also this does not seem to happen when you are zoomed in and can see the ships textures, or not that I could see. Also it seems to only happen if the ship are of the same type and zooming in or out it does seem to stop the flickering or drawing issue. This is mainly a repost from the forms I just put it here, the original post was here.

http://www.arcengames.com/forums/index.php/topic,16366.0.html
TagsNo tags attached.
Internal WeightNew

Activities

x4000Bughunter

Oct 6, 2014 8:12 pm

administrator   ~0039519

* Ported over the "sorted batched" sprite logic that is used for shots and ships in The Last Federation. This is now used for far zoom icons and shots and similar in AI War, and prevents the bulk of that flickering that previously could be seen.

* Far Zoom Icon Combination Distance is now default of 0 (and will automatically reset itself to that for everyone), rather than a default of 12.
** This causes the combination of far zoom icons to lower the number of draw calls to cease. This actually saves you some CPU, which is great, and it shows you literal icons for every ship rather than combining nearby ships into one kind of compound icon.
** This also solves the remainder of the flicker problem that has been reported in recent builds. Why this aspect of the flicker is only showing up recently is not entirely clear, but it seems related to the overall higher framerates and thus the higher rate of recalculation of these groups.
** Most importantly of all, these groups really are not important for performance reasons now, because the game is now doing the sprite batching that these were trying to work around the lack of previously. We still have the feature available in case someone does turn out to need it, but this is not expected.

Issue History

Date Modified Username Field Change
Oct 3, 2014 1:56 pm Fleet Unity New Issue
Oct 3, 2014 1:59 pm Fleet Unity Description Updated View Revisions
Oct 3, 2014 3:27 pm Fleet Unity Description Updated View Revisions
Oct 3, 2014 5:00 pm x4000Bughunter Assigned To => x4000Bughunter
Oct 3, 2014 5:00 pm x4000Bughunter Status new => assigned
Oct 6, 2014 8:12 pm x4000Bughunter Internal Weight => New
Oct 6, 2014 8:12 pm x4000Bughunter Note Added: 0039519
Oct 6, 2014 8:12 pm x4000Bughunter Status assigned => resolved
Oct 6, 2014 8:12 pm x4000Bughunter Fixed in Version => 8.015
Oct 6, 2014 8:12 pm x4000Bughunter Resolution open => fixed