View Issue Details

IDProjectCategoryLast Update
0015178The Last Federation[All Projects] Gameplay IssueMay 20, 2014 1:12 pm
ReporterMiseryAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version1.019 (Solar Wind) 
Fixed in Version1.021 (Of Armadas And Outposts) 
Summary0015178: Change joint assault quest: Currently unbalanced, can take very long time
DescriptionOk, so, I just did one of these, or tried to anyway, and while the solar map effects and benefits/downsides all make sense, the actual battle itself has alot of problems.

In my game, it was helping the Skylaxians against the Thoraxians. The battle itself though consisted of me VS way too many things at once... 18 flagships. The problem here isnt one of difficulty... getting the flagships split into manageable groups isnt that hard. The problem is mainly tedium, and the mission requiring an absurd amount of time. This is likely going to be very much the case even on lower difficulties, though obviously not quite to the extreme as the one I'm playing on.... but still, it could get very tedious and time-consuming. Any battle that has THAT many targets will have this problem.

My suggestion is to change up the structure of the mission. Since you're supposed to be breaking through orbital defenses, it would make more sense to have things other than just flagships there. Instead, perhaps make it a bit like the terraforming missions, with the defensive rings and other structures, but without the spy probes. Instead, in addition to the actual defenses, you might get 5 or 6 enemy flagships defending this area. The player's goal would not be a delivery point, but could perhaps be some sort of communications structure used for military purposes. The player docks with this for a few turns, and you could have them be essentially placing a bomb on it, and it's destruction disorients the overall defending forces enough for the race you're helping to dive in, do what they want, and dive out. This, to me, makes alot more sense than simply diving in and hammering a zillion flagships entirely on your own. In addition, it'd be a bit of a change from the feel of "normal" battles. The player would also have alot more options as to how they want to approach the whole thing. Do they try to pop some flagships before going in? Or maybe pull some of them away, before doubling back and smashing through the defensive rings to get to the structure before the enemy catches back up? Ideas like that sound alot more interesting to me.

One way or another though I do think it needs a change along that line. Right now it's just not really a viable option, and the sheer length of it alone is enough to discourage the player from doing the quest, even if the strategic benefits are obvious to them at the time.
TagsNo tags attached.
Internal WeightNew

Activities

CricketMask

May 15, 2014 6:51 am

reporter   ~0038111

Actually, 18 ships in combat aren't that bad on lower difficulties unless they keep kiting <_< And bonus points if you have disruptor, they die really fast. On misery, yes, such missions are pain, but on lower not so much.

Misery

May 15, 2014 7:44 pm

reporter   ~0038125

Last edited: May 15, 2014 7:45 pm

View 2 revisions

Maybe, but THAT many on pretty much any difficulty, on a mission that is handed to you as a quest, doesnt make sense from a gameplay standpoint.

I can understand them all being there if you made the choice entirely on your own to just randomly attack this huge fleet orbiting some planet. That makes sense, and it'd be your own mistake, like, okay, why would you attack that huge group in the first place?

But this is a quest the game decides to give you. And you HAVE to kill ALL of them to finish the quest. There needs to be some limitations for quests in general, so the player doesnt get into a situation of the game just handing them an impossible one, because then why in the world is it handing it out as a quest in the first place? The quest shouldnt be able to appear if certain numbers are beyond a certain point. Particularly considering that some quests will have consequences for NOT doing them. Balance issues with these could be a major problem considering that factor. It'd be pretty dumb to lose a huge pile of influence with someone simply because you know that either the quest they're giving is going to be impossible, or because you know it'll take 3 hours to do.

....not to mention trying to do it all with the minigun and the gravity lance (acutian ship.... sigh). While absolutely having to kill any small ships that are near them. Takes absolutely forever. 18 flagships, each with, what, 6 groups of small ships to spawn at you, and more than enough time to spawn every single one... suffice it to say, it takes.... awhile. It's not a matter of just being a pain at that point, it's downright broken when it gets that bad.

x4000Bughunter

May 20, 2014 1:12 pm

administrator   ~0038214

Thanks!

* Previously, when it came to main-government armadas to get involved in opposing you in quests, the rules were that it would just take an entire armada, and potentially move it from a really critical location to somewhere really stupid. And potentially give you 18+ flagships to chew through (ugh).
** Now the armada-getting for quests is a lot more nuanced:
*** Firstly, it tries to pull PART of an armada that is sized appropriately to the quest. But it also tries not to empty out any planetary armadas too thoroughly.
*** Secondly, if it can't find anything above, it no longer just gives up. Instead, it tries to pull emergency reserves together into an armada with the base power level that is being requested by the quest.
*** Thirdly, if THAT doesn't work, then creates an armada on the fly for the quest, but charges the highest-economy planet of that race 1/4 the base power level of the armada in economy points.
** Note that case 3 is pretty unlikely in most games, but in situations where a quest came up and then a race really got smashed to the brink, then it will come up. In those cases the quest now still is able to function without the race just getting "free armadas" (there should be a cost to everything).
** Some of the problems with armadas just being too crazy in quests came about because of recent shifts to make armadas fewer in number but larger in scope; that had an adverse effect on quests (auto-resolve could work around it, but still).
** This also solves a number of things with quests being canceled early -- not bugs at all, but situations that were nonideal and a confusing to players.

Issue History

Date Modified Username Field Change
May 15, 2014 5:56 am Misery New Issue
May 15, 2014 6:51 am CricketMask Note Added: 0038111
May 15, 2014 7:44 pm Misery Note Added: 0038125
May 15, 2014 7:45 pm Misery Note Edited: 0038125 View Revisions
May 20, 2014 1:12 pm x4000Bughunter Internal Weight => New
May 20, 2014 1:12 pm x4000Bughunter Note Added: 0038214
May 20, 2014 1:12 pm x4000Bughunter Status new => resolved
May 20, 2014 1:12 pm x4000Bughunter Fixed in Version => 1.021 (Of Armadas And Outposts)
May 20, 2014 1:12 pm x4000Bughunter Resolution open => fixed
May 20, 2014 1:12 pm x4000Bughunter Assigned To => x4000Bughunter