View Issue Details

IDProjectCategoryLast Update
0001460AI War[All Projects] Bug - OtherJan 3, 2011 11:45 am
ReporterSRombautsAssigned Tox4000Bughunter 
Severityfeature 
Status closedResolutionno change required 
Product Version4.033 
Fixed in Version 
Summary0001460: Steam version with a first update to beta version unable to detect any more updates
DescriptionI tried it twice in the past days :

First time :
- I installed the stable Steam version (4.021),
- then updated (downloading 2 files) to the beta 4.030 or similar
- after a few more days I notice no further update in the main lobby menu

So I reinstalled the full game (buying The Zenith Remnant in the process)
- 4.021 + extension
- then updated with three files this time to the beta 4.033
- now I am stuck with this one
TagsNo tags attached.
Internal Weight

Activities

SRombauts

Nov 18, 2010 6:13 pm

reporter   ~0003918

Bug linked to the support topic "How to manually update the game?" :
http://www.arcengames.com/forums/index.php/topic,7657.0.html


from X4000:
Meanwhile, if you want the raw zip files, you can get a list of them here: http://www.arcengames.com/dl/AIWarBetaUpdates2.xml

Simply unzipping them into your game folder in order would give the desired result if you want the betas that way. Hope that helps

SRombauts

Nov 18, 2010 6:18 pm

reporter   ~0003919

The manual ZIP update worked for me and bring me to 4.037 :)

x4000Bughunter

Nov 18, 2010 7:36 pm

administrator   ~0003921

There's not a known bug of this sort -- most likely something has noticed that the AIWar executable has changed and that therefore it is unable to allow further updates. Are you running any particular antivirus software? What OS are you on? Most likely it's scanning software denying the internet connection for the game after it's been updated; it could actually be a firewall, too.

Hope that helps!

SRombauts

Nov 19, 2010 1:47 am

reporter   ~0003962

I'am on Windows 7 Home Premium up-to-date, with the default firewall and the Microsoft Security Essentials antivirus suite.

Yes I think it might be the firewall (there is an AI War entry in the exception list) perhaps that Steam automatically add an exception for AI War but then the update invalidate it, I'll try to investigate when you will publish next beta update.

SRombauts

Nov 20, 2010 8:57 pm

reporter   ~0004126

Bad news, even whith the firewall of Windows 7 deactivated, AI War does not find the new update beta 4.038

As a workaround, I can still download the ZIP here http://www.arcengames.com/dl/AIWarBetaUpdates2.xml

Next time, I'll try a non steam version of AI War on the same computer, to see...

ArcDM

Nov 20, 2010 9:42 pm

reporter   ~0004127

at having version 4.037 my version sees a update for AI War

I have vista and i got the game through steam months ago along with both expansions as soon as they were available on steam

This might be a steam issue, have you checked the integrity of game cache?

x4000Bughunter

Nov 21, 2010 10:00 am

administrator   ~0004142

I'm not sure what to say, other than there is some other software that's interfering -- if the steam version launches at all, it has all the code. And the code is identical there and everywhere else. So that just means that, for some reason, the game isn't able to connect out to the internet and find the update on your machine.

You could also try checking in the Settings window of the game to make sure that the updates automatic checking is turned on, but I assume you would have brought it up if that had been turned off. It's possible that your antivirus software also contains a firewall that you aren't aware is even running -- that happens more than you'd think. I don't know anything about the specific firewall you mention, though.

SRombauts

Nov 21, 2010 11:41 am

reporter   ~0004145

Ok, shame on me !

I don't no why but the "auto-update on startup checkbox" seems to be unchecked between the installation by Steam (where it is definitely checked) and the first auto-uptade.

So ca I rename this issue report for this strange behavior ? I can do some more test for you ?

x4000Bughunter

Nov 22, 2010 9:40 am

administrator   ~0004197

Ok, glad that's all it was. I'm not aware of anything that would programmaty change that setting, so I assume it was just a mid-click at some point in the past. No worries! Let us know if it seems to mysteriously happen again, though.

Issue History

Date Modified Username Field Change
Nov 18, 2010 6:08 pm SRombauts New Issue
Nov 18, 2010 6:13 pm SRombauts Note Added: 0003918
Nov 18, 2010 6:18 pm SRombauts Note Added: 0003919
Nov 18, 2010 7:36 pm x4000Bughunter Note Added: 0003921
Nov 18, 2010 7:36 pm x4000Bughunter Assigned To => x4000Bughunter
Nov 18, 2010 7:36 pm x4000Bughunter Status new => feedback
Nov 19, 2010 1:47 am SRombauts Note Added: 0003962
Nov 19, 2010 1:47 am SRombauts Status feedback => assigned
Nov 20, 2010 8:57 pm SRombauts Note Added: 0004126
Nov 20, 2010 9:42 pm ArcDM Note Added: 0004127
Nov 21, 2010 10:00 am x4000Bughunter Note Added: 0004142
Nov 21, 2010 10:00 am x4000Bughunter Status assigned => feedback
Nov 21, 2010 11:41 am SRombauts Note Added: 0004145
Nov 21, 2010 11:41 am SRombauts Status feedback => assigned
Nov 22, 2010 9:40 am x4000Bughunter Note Added: 0004197
Nov 22, 2010 9:40 am x4000Bughunter Status assigned => resolved
Nov 22, 2010 9:40 am x4000Bughunter Resolution open => no change required
Jan 3, 2011 11:45 am x4000Bughunter Status resolved => closed