View Issue Details

IDProjectCategoryLast Update
0014308The Last FederationCrash/ExceptionApr 24, 2014 11:44 am
Reporterprgltg Assigned ToChris_McElligottPark  
Status closedResolutionno change required 
Product Version1.001 (Bugfixes, Large Screen Resolution Support) 
Summary0014308: Game freezes
DescriptionJust bought the game today on Steam. First time I try to run it I get as far as the first mission screen loading up and telling me I was on my flagship and it was going to introduce me to combat, and it freezes. I end the task in task manager, go back in, and don't even get that far the next time. I uninstall the game, re install it, and it freezes every time. The screen come ups saying 1Gameinit, the number starts to increment, and then it freezes.
TagsNo tags attached.
Internal WeightNew


related to 0014561 closedChris_McElligottPark Game fails to load 



Apr 20, 2014 8:17 pm

administrator   ~0036343

There's a thread here where we're trying to hunt down the cause of that for someone else: [^]

But relevant snippets:


Most likely it's just a corrupt download -- that happens sometimes with Steam. All you have to do is verify your local file cache in those circumstances, and that tends to solve it.


Oh! Apologies, the other thing it could be is antivirus. Avast and Kaspersky are known for killing Unity 3D engine games for no real reason. With those, and occasionally other antivirus programs, all you have to do is make an exception for the game executable to say that it's okay, and that solves the issue.


(If still not working)

Are you sure there is no other antivirus in there messing with it? Or antispyware programs? On launch the game does check an amazon s3 file to see if there is an update available for the game, and some anti-whatever programs freak out about that.

In terms of launching directly instead of from steam, I have no idea why that would be the case, that's a new one on me. What OS? Are there error logs that you can post from the RuntimeData folder? Also, if you are on windows or linux, in the LastFederation_Data or LastFederationLinux_Data folders, there is an output.log file that would be useful to have to look at.


Well, you can try unzipping this into your game folder: [^] It goes inside the RuntimeData subfolder. That turns off the automatic check for updates, as well as putting you in windowed mode instead of fullscreen mode.

Based on the logs you are sending me, neither the unity engine nor our game logic is logging any error whatsoever. Any error of any significance, anyway (there is a binding to the steam dll failure note, but that affects nothing).

So what that tells me is that some other process is either actively killing the unity engine process, or trying to inject something into it that makes it die. An example of a program that injects itself into other programs is actually Steam: it puts in the steam overlay and all that good stuff for any game you launch from steam. There are some other similar programs out there that do this, like XFire and similar. We haven't had any known issues with anything like that in a while, but it could be that some program of that sort is causing an issue.

Hopefully it's just still the game being killed because it has the audacity to check for updates. ;) In that case, the settings file I provided, if you put it in that RuntimeData subfolder, prevents any sort of internet connections from being launched at all within the game, and thus should prevent any security software from killing it.


Also, here is some more information from another unity game, same issue -- this one being Realms of Arkania, but it's all the same thing when it comes to outside stuff killing the unity engine: [^]


Hope one of those things helps!


Apr 23, 2014 7:40 pm

reporter   ~0036595

Tried installing the file, and still have the same issue. I excluded the entire steam folder form my antivirus (Trend Micro), same issue still. It even happens when I disable my antivirus completely. Very frustrating.


Apr 23, 2014 8:59 pm

administrator   ~0036599

Here's another bit from the steam forums that I posted:

Well... I'm doing general googling on other unity games, because most likely it's something that affects all of them given when you are seeing the crashes. There is some good stuff on the Kerbal Space Program page here:

I hope one of those helps! Some of the items there were news to me -- particularly the thing with multi-core processors on 32bit machines causing issues, and the Athlon issue. Fortunately they've figured out solutions to those oddities and have posted them in a handy FAQ.

Even though you use Microsoft Security Essentials, I would also think that the notes about putting an exception on the entire steam folder as a test might work.


Apr 23, 2014 9:14 pm

administrator   ~0036600

One more thing crossposted from the forums side:

Okay, well, I am afraid I don't really have a lot to go on. Right now the situation is that the game works for the incredible vast majority of people (12k and counting), and of the small minority that it doesn't, usually antivirus thing fixes it.

Of the minority for which it still doesn't work, so far all those people are on various versions of windows, and there are somewhere under 10 who have posted anything about it (though I understand there may be more lurkers).

I'm not trying to throw anything in your face or go "obviously there's no problem here," because you clearly can't run the game, and that's problem. But I need you to meet me halfway somewhere. Right now there's nothing you've reported that is out of the ordinary except the fact itself that it doesn't start. There's no unusual software reported, comparable games work for you, you're on practically the same OS and hardware as my main machine, and neither our code nor the unity engine is producing any error logs whatsoever.

From my perspective, that means I am shooting incredibly much in the dark. Something is different on your machine, but I don't have any idea what as yet. Given that your computer meets the specs for the game, and that this is not a common occurrence with players, I can only conclude there has to be some sort of outside software interfering. If it were getting to our code and then running out of RAM or throwing exceptions or something, that would be different, but that's not what we have here.

In the past, there were some people using the Korean Microsoft Office Language Bar (or something to that effect), and that was causing problems with a variety of games, including ours. I presume that would impact Kerbal as well if that were the case, though, which is what makes this extra perplexing; if this were all unity games, that would make a lot more sense.

You might try the solution under the "Windows Data Execution Prevention (DEP)" section on that Kerbal Space Program Link. Please make sure that your local user account has full read and write permissions to that folder. For that matter, please make sure that's the case on the steam side. If it runs from the other location but not the primary one, then perhaps that is the issue.

If you want to post a dxdiag, I can take a look at it and see if I spot anything unusual, although that's a longshot -- in five years, I've never had one of those be useful, but there's a first time for everything.

Another thing that occurs to me is that maybe you actually have some form of malware or virus on this particular machine. This again is a longshot, as I would think that it would affect far more than this. But you might try doing a scan of your machine using Spybot Search And Destroy and/or some other program. Microsoft Security Essentials is something I have found to be... not a perfect shield against all things, to be frank.

I... hmmm. I really am grasping at straws here at this point. I've never had a player in 5 years who just outright couldn't run one of our games, and I'm not about to start now, dangit! ;) But at the moment you have me moderately stumped, to say the least. So sorry about all the hassle with this, I know it's no fun from your end either.


Apr 23, 2014 10:21 pm

reporter   ~0036605

I understand how frustrating shooting in the dark can be, I work as a programmer myself. I have managed to get the game to run now. I read several people post similar issues in some other unity games, and a common thread seemed to be that people still on Vista could run the game. I launched the game from the app folder in Steam, and set it to run in Vista Compatibility mode, and am able to play it just fine. (Windows 8.1 machine)


Apr 24, 2014 11:44 am

administrator   ~0036657

Awesome, thank you for posting the solution!

Issue History

Date Modified Username Field Change
Apr 20, 2014 4:08 pm prgltg New Issue
Apr 20, 2014 8:17 pm Chris_McElligottPark Note Added: 0036343
Apr 20, 2014 8:17 pm Chris_McElligottPark Assigned To => Chris_McElligottPark
Apr 20, 2014 8:17 pm Chris_McElligottPark Status new => feedback
Apr 23, 2014 7:40 pm prgltg Note Added: 0036595
Apr 23, 2014 7:40 pm prgltg Status feedback => assigned
Apr 23, 2014 8:59 pm Chris_McElligottPark Note Added: 0036599
Apr 23, 2014 9:14 pm Chris_McElligottPark Note Added: 0036600
Apr 23, 2014 10:21 pm prgltg Note Added: 0036605
Apr 24, 2014 11:44 am Chris_McElligottPark Relationship added related to 0014561
Apr 24, 2014 11:44 am Chris_McElligottPark Internal Weight => New
Apr 24, 2014 11:44 am Chris_McElligottPark Note Added: 0036657
Apr 24, 2014 11:44 am Chris_McElligottPark Status assigned => closed
Apr 24, 2014 11:44 am Chris_McElligottPark Resolution open => no change required