View Issue Details

IDProjectCategoryLast Update
0012779Bionic Dues[All Projects] Bug - GameplaySep 30, 2013 5:29 pm
Reporternas1mAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.926 
Fixed in Version 
Summary0012779: No loot granted by Science Station mission
DescriptionThe mission summary is empty aside from the "You won" message.
See attached screenshot and save.
TagsNo tags attached.
Internal WeightMajor Problem

Activities

nas1m

Sep 30, 2013 2:44 pm

reporter  

Ironman_2.save (5,654 bytes)

nas1m

Sep 30, 2013 2:45 pm

reporter  

2013-09-30_00001.jpg (266,563 bytes)

nas1m

Sep 30, 2013 3:08 pm

reporter   ~0034319

Happens for the second science station next to the HQ as well in case you need to reproduce it (forgot to save before trying it, sorry = /).

keith.lamothe

Sep 30, 2013 3:32 pm

administrator   ~0034320

Ok, I can't reproduce this. I've tried:

1.a) Load the save.
1.b) Start the mission.
1.c) Walk to the exit.
1.d) Observe mission result window.

and

2.a) Load the save.
2.b) Start the mission.
2.c) Walk to one tile adjacent to the exit.
2.d) Save & Quit
2.e) Close the application
2.f) Restart the application
2.g) Load the save
2.h) Take the last step onto the exit
2.i) Observe mission result window.

And in both cases the mission result window looks exactly as expected.

Can you give me steps to reproduce? With this save or any other.

Thanks :)

nas1m

Sep 30, 2013 3:44 pm

reporter   ~0034321

Hm. I am not able to reproduce the issue using both approaches as well.
It might have been that I made my second attempt still using .926, so maybe it was some variant of the autosave bug, but without rendering the save completely useless...

I will cry wolf if it happens again. I am just happy I made a screenshot - just so you know I did not see ghosts ; )...

keith.lamothe

Sep 30, 2013 5:29 pm

administrator   ~0034324

Ok, I'll call this one done unless you see it again, but if you do please reopen this or start a new mantis record :)

Issue History

Date Modified Username Field Change
Sep 30, 2013 2:44 pm nas1m New Issue
Sep 30, 2013 2:44 pm nas1m File Added: Ironman_2.save
Sep 30, 2013 2:45 pm nas1m File Added: 2013-09-30_00001.jpg
Sep 30, 2013 3:08 pm nas1m Note Added: 0034319
Sep 30, 2013 3:32 pm keith.lamothe Note Added: 0034320
Sep 30, 2013 3:32 pm keith.lamothe Assigned To => keith.lamothe
Sep 30, 2013 3:32 pm keith.lamothe Status new => feedback
Sep 30, 2013 3:39 pm keith.lamothe Internal Weight => Major Problem
Sep 30, 2013 3:44 pm nas1m Note Added: 0034321
Sep 30, 2013 3:44 pm nas1m Status feedback => assigned
Sep 30, 2013 5:29 pm keith.lamothe Note Added: 0034324
Sep 30, 2013 5:29 pm keith.lamothe Status assigned => resolved
Sep 30, 2013 5:29 pm keith.lamothe Resolution open => fixed