View Issue Details

IDProjectCategoryLast Update
0012593Bionic Dues[All Projects] Bug - GameplaySep 20, 2013 11:53 am
ReporterMiseryAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.917 - Please Still Keep An Eye Out 
Fixed in Version0.918 - Better, But Please Keep Watch 
Summary0012593: AI has gone completely insane
DescriptionYeah, that's really the best way to describe what's happening. I've got bots choosing destinations randomly, bots chasing after virused bots but not shooting at them OR at the Exos if I move into their range, even if I just stand there, there's lots of instances of bots randomly going berserk and firing on each other (and this seems to happen to many bots all at once), I've got sentries shooting at other sentries (and I'll bet they'll shoot at me if I stick around them long enough), virused bots roaming around randomly for no apparent reason.... the list goes on. All of these different things are extremely frequent. Missions devolve into total chaos within 30 turns or so.
TagsNo tags attached.
Internal WeightFix ASAP

Activities

tigersfan

Sep 20, 2013 9:34 am

reporter   ~0033893

Do you have a save of this happening? We can't seem to repro this.

Misery

Sep 20, 2013 10:09 am

reporter  

SentriesBug.save (84,067 bytes)

Misery

Sep 20, 2013 10:10 am

reporter  

BotglitchAim.save (83,854 bytes)

Misery

Sep 20, 2013 10:14 am

reporter   ~0033895

Ok, I've gone and set up two saves here (both in the same mission) that are reproducing some of the effects reliably every time I load them.

For the SentriesBug save, the Exo is already in position, just drop a sentry right there and the others should instantly fire at it.

For the BotGlitchAim save, the sniper is already standing in their firing range, start walking towards them; they will not fire. Walk closer to them and when you're a couple of steps away, a bunch of attacks from random nearby bots will hit some other nearby bots. There's a RazorBot in the group, but the damage log shows it's the other ones doing the damage, at entirely random targets. Sometimes moving around further causes them to fire at each other some more, sometimes they'll turn and start aiming at the Exo again.

x4000Bughunter

Sep 20, 2013 11:50 am

administrator   ~0033908

Part 1:

* Fixed a bug where sentry turrets would attack other sentry turrets as soon as you placed the new one, but no further.

Also of note: bots attacking other bots is not a bug, when it comes to the types like RazorBot that are HatesEveryone. It was actually a pre-.917 a bug that the bots did not fight back against them and virused bots, fixed in .917. Also also, in your savegame here it has the BlasterMaster, which causes bots to miss and hit adjacent bots. Also pre-.917 there was a bug that was causing them to not be able to actually hit their teammates on those tiles, but .917 also fixed that. Hence the new behavior in these two specific cases.

x4000Bughunter

Sep 20, 2013 11:53 am

administrator   ~0033909

Playing through BotglitchAim, at least on my current build of .918, I see that it is working correctly. And based on your reports above, I think it is also working right.

Basically, here is what is happening:
1. Bots are trying to hit the RazorBot, since it is closest.
2. The BlasterMaster is giving them the "miss every other shot" thing.
3. They are missing the RazorBot and hitting other bots next to him.
4. This exchange of fire happens back and forth until the RazorBots are dead.
5. Then they turn their attention to you.
6. If you walk close enough prior to all this carnage, they will also turn on you.

So, all seems well!

Issue History

Date Modified Username Field Change
Sep 20, 2013 1:19 am Misery New Issue
Sep 20, 2013 9:23 am tigersfan Internal Weight => Fix ASAP
Sep 20, 2013 9:23 am tigersfan Assigned To => x4000Bughunter
Sep 20, 2013 9:23 am tigersfan Status new => assigned
Sep 20, 2013 9:34 am tigersfan Note Added: 0033893
Sep 20, 2013 10:09 am Misery File Added: SentriesBug.save
Sep 20, 2013 10:10 am Misery File Added: BotglitchAim.save
Sep 20, 2013 10:14 am Misery Note Added: 0033895
Sep 20, 2013 11:50 am x4000Bughunter Note Added: 0033908
Sep 20, 2013 11:53 am x4000Bughunter Note Added: 0033909
Sep 20, 2013 11:53 am x4000Bughunter Status assigned => resolved
Sep 20, 2013 11:53 am x4000Bughunter Fixed in Version => 0.918 - Better, But Please Keep Watch
Sep 20, 2013 11:53 am x4000Bughunter Resolution open => fixed