View Issue Details

IDProjectCategoryLast Update
0001196AI War[All Projects] Bug - OtherNov 20, 2010 3:03 pm
ReporterKleenexAssigned Tokeith.lamothe 
Severitymajor 
Status resolvedResolutionfixed 
Product Version4.030 
Fixed in Version 
Summary0001196: Enemies attacking Mass Driver under a shield do massive damage when it falls
DescriptionThere were about 200 impulse reaction emitters attacking an orbital mass driver that i captured. They were doing very little damage but i still felt like stalling them a bit so i built a shield next to it. The emitters chewed through the shield very quickly, but when the shield got low enough that the mass driver was exposed the mass driver started taking massive damage and died in a few seconds.

I have attached screenshots and a save file.
TagsNo tags attached.
Internal Weight

Activities

Kleenex

Nov 8, 2010 8:45 pm

reporter  

Screenshot_2010_11_08_17_43_26.png (1,356,972 bytes)

Kleenex

Nov 8, 2010 8:46 pm

reporter  

Screenshot_2010_11_08_17_43_58.png (1,274,861 bytes)

Kleenex

Nov 8, 2010 8:46 pm

reporter  

Screenshot_2010_11_08_17_44_21.png (1,546,977 bytes)

Kleenex

Nov 8, 2010 8:47 pm

reporter  

Screenshot_2010_11_08_17_44_22.png (1,565,526 bytes)

Kleenex

Nov 8, 2010 8:48 pm

reporter  

mass driver.sav (747,211 bytes)

DakaSha

Nov 8, 2010 9:20 pm

reporter   ~0003029

I fired up that save game and also tested what would happen to the command station. same thing.

It seems like the ships are doing the same damage to the things under the shield that they were doing to the shield itself. Or the energy-attack-bonus is being applied

True-Chaos

Nov 8, 2010 10:35 pm

reporter   ~0003033

Likely the same bug so I'll post it here...

If a missile immune item is under a force field then the force field becomes missile immune.. Quick test is the AI home command station, Zenith starships will not attack the force field until after the command station is destroyed

TechSY730

Nov 8, 2010 10:36 pm

reporter   ~0003034

Last edited: Nov 8, 2010 10:37 pm

View 2 revisions

Adjusted the severity, as if this bug is real, this is a major problem.

Lancefighter

Nov 9, 2010 1:01 am

reporter   ~0003037

the issue is more that the damage is applied when the shot is fired, not when it hits.

For instance, if you take a ship, get it shot at, then move it under a forcefield, the forcefield will get hit, however it would be adjusted for the target ship's armor.
any further attacks land on the ff and have the ff's armor applied (usually none)

Now, my assumption of whats happening, is that the IRE's are shooting the forcefield, which has a higher energy use. The forcefield recalculates how much radius it has, and decides the mass driver is no longer protected, but any shots still heading towards the mass driver have the forcefield's energy applied already.. meaning that when they hit, the damage will be multiplied by the wrong number.

This theory, however, does not work for true-chaos' statement of missile immune enemies, however, i believe the logic for counter-shots might be slightly different.

orzelek

Nov 9, 2010 3:42 am

reporter   ~0003041

If this issue translates to FF Bearers then it would mean that after recent armor nerf for them taking them with you means that your ships will take more damage then they should... and that before the nerf they looked very powerful since their armor was applied sometimes to targets they protected.

zebramatt

Nov 9, 2010 7:55 am

reporter   ~0003052

I think the title of this bug needs to more generally state the root of the issue; but I can't for the life of me put it succinctly!

DakaSha

Nov 9, 2010 7:56 am

reporter   ~0003053

Last edited: Nov 9, 2010 7:57 am

View 3 revisions

Force Fields Bugged :P

edit: you could throw in a "massively" for good effect ^^

keith.lamothe

Nov 9, 2010 2:28 pm

administrator   ~0003084

Looking into the ff-protected-item-getting-damage-intended-for-forcefield side of the bug right now. Can someone post a save demonstrating the ff-immune-to-missiles-if-any-protected-item-is-immune-to-missiles side of it?

True-Chaos

Nov 9, 2010 11:18 pm

reporter  

Test-FF-Bug.sav (50,547 bytes)

True-Chaos

Nov 9, 2010 11:19 pm

reporter   ~0003144

Save uploaded. 15 or so Spire starships just outside the 1st AI homeworlds commandstation shield

keith.lamothe

Nov 20, 2010 3:03 pm

administrator   ~0004105

Chris recently changed shots to calculate damage upon hit rather than upon firing, so this should be taken care of now.

Issue History

Date Modified Username Field Change
Nov 8, 2010 8:44 pm Kleenex New Issue
Nov 8, 2010 8:45 pm Kleenex File Added: Screenshot_2010_11_08_17_43_26.png
Nov 8, 2010 8:46 pm Kleenex File Added: Screenshot_2010_11_08_17_43_58.png
Nov 8, 2010 8:47 pm Kleenex File Added: Screenshot_2010_11_08_17_44_21.png
Nov 8, 2010 8:47 pm Kleenex File Added: Screenshot_2010_11_08_17_44_22.png
Nov 8, 2010 8:48 pm Kleenex File Added: mass driver.sav
Nov 8, 2010 8:53 pm Kleenex Description Updated View Revisions
Nov 8, 2010 8:53 pm Kleenex Description Updated View Revisions
Nov 8, 2010 9:20 pm DakaSha Note Added: 0003029
Nov 8, 2010 10:35 pm True-Chaos Note Added: 0003033
Nov 8, 2010 10:36 pm TechSY730 Note Added: 0003034
Nov 8, 2010 10:36 pm TechSY730 Priority normal => high
Nov 8, 2010 10:36 pm TechSY730 Severity minor => major
Nov 8, 2010 10:37 pm TechSY730 Note Edited: 0003034 View Revisions
Nov 9, 2010 1:01 am Lancefighter Note Added: 0003037
Nov 9, 2010 3:42 am orzelek Note Added: 0003041
Nov 9, 2010 7:55 am zebramatt Note Added: 0003052
Nov 9, 2010 7:56 am DakaSha Note Added: 0003053
Nov 9, 2010 7:57 am DakaSha Note Edited: 0003053 View Revisions
Nov 9, 2010 7:57 am DakaSha Note Edited: 0003053 View Revisions
Nov 9, 2010 2:28 pm keith.lamothe Note Added: 0003084
Nov 9, 2010 11:18 pm True-Chaos File Added: Test-FF-Bug.sav
Nov 9, 2010 11:19 pm True-Chaos Note Added: 0003144
Nov 20, 2010 3:03 pm keith.lamothe Note Added: 0004105
Nov 20, 2010 3:03 pm keith.lamothe Status new => resolved
Nov 20, 2010 3:03 pm keith.lamothe Resolution open => fixed
Nov 20, 2010 3:03 pm keith.lamothe Assigned To => keith.lamothe