View Issue Details

IDProjectCategoryLast Update
0011033AI War[All Projects] Bug - GameplayApr 2, 2013 4:38 pm
ReporterWingflierAssigned Tokeith.lamothe 
Severitytweak 
Status resolvedResolutionfixed 
Product Version6.015 
Fixed in Version6.016 
Summary0011033: Bug causes allied minor faction ships to simply set on an empty planet and do nothing
DescriptionThis has bug has been around for awhile, I've just never gotten around to bringing it up.

Basically the issue is this: Allied minor faction ships have some kind of planet targeting system, and often times when no adjacent enemy planets fall into this category, they instead will just sit on a neutral planet (typically the one they were spawned at) for hours, doing absolutely nothing.

In my current game, there are over 100 allied minor faction units sitting on the Dyson planet, not doing anything.

I propose we add a trigger to the allied minor faction logic that, if they have nothing else to do, they go to the nearest allied planet and begin a patrol. Thank you. Save attached.
TagsNo tags attached.
Internal WeightNew

Activities

Wingflier

Mar 30, 2013 10:19 pm

reporter  

DOSOMETHING.sav (165,647 bytes)

keith.lamothe

Apr 2, 2013 4:38 pm

administrator   ~0031444

Last edited: Apr 2, 2013 4:39 pm

View 2 revisions

For 6.016:

* Fixed a longstanding (back to the beginning of Ancient Shadows) bug where some minor faction ships could get stuck on a planet's central point because they were trying to path to a nebula (but obviously could not actually do so).

Thanks!


After fixing that, I loaded the save back up and that clump of units proceeded to thoroughly clean the two adjacent AI planets, though they don't go further out than that (just bounce back and forth between those three planets, killing whatever reinforcements or SF show up).

Issue History

Date Modified Username Field Change
Mar 30, 2013 10:19 pm Wingflier New Issue
Mar 30, 2013 10:19 pm Wingflier File Added: DOSOMETHING.sav
Mar 30, 2013 10:22 pm Wingflier Description Updated View Revisions
Apr 2, 2013 4:38 pm keith.lamothe Internal Weight => New
Apr 2, 2013 4:38 pm keith.lamothe Note Added: 0031444
Apr 2, 2013 4:38 pm keith.lamothe Status new => resolved
Apr 2, 2013 4:38 pm keith.lamothe Fixed in Version => 6.016
Apr 2, 2013 4:38 pm keith.lamothe Resolution open => fixed
Apr 2, 2013 4:38 pm keith.lamothe Assigned To => keith.lamothe
Apr 2, 2013 4:39 pm keith.lamothe Note Edited: 0031444 View Revisions