View Issue Details

IDProjectCategoryLast Update
0010070Valley 2Bug - GameplayFeb 13, 2013 5:43 pm
Reporternas1mAssigned To 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.706 
Fixed in Version0.807 
Summary0010070: Spells sometimes do not trigger using gamepad controls
DescriptionWhile attempting to perform small spell combos (i.e. alternatingly release my primary and secondary) or to block incoming spells using high caliber touch spells pressing the respective button often does nothing.

This is most recognizable if holding a button (e.g. the primary attack) and then trying to use another spell by pressing another button (and releasing the previous button obviously).

As it is this behaviour prevents me from using spell combos and/or blocks
and forces me to simply spam a single spell of high caliber (and low damage) to get past most henchmen, which feels like the combat mechanics are not living up to their potential...
TagsNo tags attached.
Internal WeightFeature Suggestion

Activities

tigersfan

Dec 20, 2012 2:32 pm

reporter   ~0029203

Is anyone else seeing this? I play with a gamepad almost exclusively, and I've never run across this.

nas1m

Dec 27, 2012 11:05 am

reporter   ~0029327

Last edited: Jan 2, 2013 3:17 pm

View 4 revisions

After some more playtime with .707 I think I finally got to the bottom of what exactly is my issue.

As I see it the behavior described above happens using all control types (including keyboard only) if using a mage class with more or less greatly differing cooldowns on their spells.

In my current game the issue is fairly obvious if using the tier 2 fire-themed mage class (I think it is caused Ashist?).

All spells of this class have a fairly high cooldown, especially as far as the primary and secondary spells are concerned. Additionally the ammo based spell does only deal a minor amount of damage but has an extremely high caliber at a fairly low ammo cost.

Assuming that the ammo based spell is intended for blocking I often tried to trigger it to block an incoming attack. If I casted the primary or secondary spell before (I'm in battle after all) the ammo spell simply won't trigger most of the time - presumably because the cooldown of the last triggered spell does not only apply to the casted spell itself but to all other spells as well, i.e. I am not able to cast *any* other spell while the last triggered spell is on cooldown.

Whether this is a bug or not depends on your design, of course. I am not going to say this behavior is wrong, but it feels very counter-intuitive to me and is currently the sole (but fairly significant) source of frustration for me when playing Valley 2.

Furthermore I think it discourages many things (I think) you want to achieve with your new combat system (which is loads of fun otherwise!) as it actively discourages using multiple spells of a given mage class and a more tactical combat by the ability to block spells.

Not being able to cast a spell for almost a second is simply no fun - especially in the heat of battle.

Hope this helps!

PS: Apparently my note changed the status of the task from feedback to new. This was not intended, so please feel free to reset it again. Sorry for the inconvenience.

zaaq

Dec 28, 2012 9:58 am

reporter   ~0029336

I've noticed this as well w/ the tier-1 fire mage (campfire special attack doesn't always trigger when I expect it to), always attributed it to cooldowns.

Perhaps displaying the cooldowns for each ability (like in an MMO interface) would get around the issue?

nas1m

Jan 2, 2013 3:24 pm

reporter   ~0029442

I would prefer a solution where the cooldown of the last triggered spell is only applied to this spell and all remaining spells can be cast instantly.

A side-effect of this approach could be that a very long cooldown could be bypassed by casting another spell in between - but this is more of an advantage in my book as it actively encourages the player to think about spell combos (which does warrant a bit of a "treat" in my opinion)...

There might be cases/spells where this would be difficult to balance, though...

tigersfan

Feb 13, 2013 5:43 pm

reporter   ~0030746

Just in for .807

* Spells should no longer prevent other spells from firing after the .2 second global cooldown.
** The only exception to this are the intentionally paired Mass and Burst spells.

Issue History

Date Modified Username Field Change
Dec 20, 2012 1:50 pm nas1m New Issue
Dec 20, 2012 2:32 pm tigersfan Internal Weight => Discussion Only
Dec 20, 2012 2:32 pm tigersfan Note Added: 0029203
Dec 20, 2012 2:32 pm tigersfan Status new => feedback
Dec 27, 2012 11:05 am nas1m Note Added: 0029327
Dec 27, 2012 11:05 am nas1m Status feedback => new
Dec 27, 2012 11:06 am nas1m Note Edited: 0029327 View Revisions
Dec 27, 2012 11:08 am nas1m Note Edited: 0029327 View Revisions
Dec 28, 2012 9:58 am zaaq Note Added: 0029336
Jan 2, 2013 11:11 am tigersfan Internal Weight Discussion Only => Feature Suggestion
Jan 2, 2013 11:11 am tigersfan Status new => strongly considering
Jan 2, 2013 3:17 pm nas1m Note Edited: 0029327 View Revisions
Jan 2, 2013 3:24 pm nas1m Note Added: 0029442
Feb 13, 2013 5:43 pm tigersfan Note Added: 0030746
Feb 13, 2013 5:43 pm tigersfan Status strongly considering => resolved
Feb 13, 2013 5:43 pm tigersfan Resolution open => fixed
Feb 13, 2013 5:43 pm tigersfan Fixed in Version => 0.807