View Revisions: Issue #21811

Summary 0021811: Selection is lost after traversing wormhole (precise case)
Revision Oct 15, 2019 12:35 pm by OzoneGrif
Description Reported here: https://bugtracker.arcengames.com/view.php?id=21783
The issue is still present

"When a fleet traverses a wormhole, it's selection is lost. This issue only occurs if the selection was made in the planet view. If you select the fleet on the galaxy map, it works correctly."

Step to reproduce:
* Start a new game (ie. basic scenario 1)
* Left-Click on your Fleet (do **not** use the hotkey or galaxy map, just click on the 3d model with the left-mouse button)
* Ctrl+Right-Click a wormhole to traverse it
* Wait to traverse the wormhole...

-> Selection is lost, your Fleet is not selected anymore; it should stay selected

This also works with units and with drag'n drop selection instead of left-click, in the planet view.

Now if you do it with the hotkey, or on the galaxy map, it works fine.
Revision Oct 15, 2019 12:34 pm by OzoneGrif
Description Reported here: https://bugtracker.arcengames.com/view.php?id=21783
The issue is still present

"When a fleet traverses a wormhole, it's selection is lost. This issue only occurs if the selection was made in the planet view. If you select the fleet on the galaxy map, it works correctly."

Step to reproduce:
* Start a new game (ie. basic scenario 1)
* Left-Click on your Fleet (do **not** use the hotkey or galaxy map, just click on the 3d model with the left-mouse button)
* Ctrl+Right-Click a wormhole to traverse it

-> Selection is lost, your Fleet is not selected anymore; it should stay selected

This also works with units and with drag'n drop selection instead of left-click, in the planet view.

Now if you do it with the hotkey, or on the galaxy map, it works fine.