View Issue Details

IDProjectCategoryLast Update
0024849AI War 2Crash/ExceptionJun 4, 2021 8:10 pm
Reporterwen1now Assigned Tox4000Bughunter  
Severitycrash 
Status closedResolutionunable to reproduce 
Product Version2.901 AIP Reduction Clarity 
Summary0024849: launching game causes system crash (very old version on osx opengl)
Description- macos catalina
- on game launch, screen turns black after approx. 5s
- system crashes and restarts after approximately 10s

Error log below [for whatever reason, the file deleted itself after I copied the contents, so I only have text rip]:

Mono path[0] = '/Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/Resources/Data/Managed'
Mono config path = '/Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/MonoBleedingEdge/etc'
Initialize engine version: 2019.1.7f1 (f3c4928e5742)
GfxDevice: creating device client; threaded=1
Renderer: Intel(R) Iris(TM) Plus Graphics OpenGL Engine
Vendor: Intel Inc.
Version: 4.1 INTEL-14.7.8
GLES: 0
 GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_framebuffer_multisample_blit_scaled GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_fl
ush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
OPENGL LOG: Creating OpenGL 4.1 graphics device ; Context level <OpenGL 4.1> ; Context handle -1786568704
Begin MonoManager ReloadAssembly
- Completed reload, in 0.152 seconds
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
UnloadTime: 2.272733 ms
Fallback handler could not load library /Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/Frameworks/MonoEmbedRuntime/osx/libGalaxyCSharpGlue
Fallback handler could not load library /Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x7faf84277000.dylib
Material SpriteEmission_Gears doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Gears doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Gears doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Gears doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Gears doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Gears doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Science doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Material SpriteEmission_Hacking doesn't have _StencilComp property
 
(Filename: ./Runtime/Export/Debug/Debug.bindings.h Line: 48)

Fallback handler could not load library /Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x7faf9c6d7000.dylib
Fallback handler could not load library /Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x7faf7656c000.dylib
Fallback handler could not load library /Users/Wen/Library/Application Support/Steam/steamapps/common/AI War 2/AIWar2.app/Contents/Frameworks/MonoEmbedRuntime/osx/data-0x7faf95c55e00.dylib
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 UNorm format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGBA Compressed BC7 sRGB format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture
Setting up 4 worker threads for Enlighten.
  Thread -> id: 70000c5e6000 -> priority: 1
  Thread -> id: 70000c669000 -> priority: 1
  Thread -> id: 70000c6ec000 -> priority: 1
  Thread -> id: 70000c76f000 -> priority: 1
TagsNo tags attached.

Activities

x4000Bughunter

May 8, 2021 3:05 pm

administrator   ~0061426

Thanks for the report -- this is the unity player log, but from what I am seeing with it this looks like a very old version of the game. I am kind of puzzled. The stencilcomp things I fixed months ago, and "WARNING: RGB Compressed BC6H UFloat format is not supported, decompressing texture" would mean you are running this in OpenGL, which we removed support for months ago in favor of just Metal on OSX.

There is another log inside the game install folder, in GameData, called ArcenDebugLog.txt. This one doesn't get deleted on restart of the game (that's what happens with the other one, which is generated by unity directly). My best guess is that you're on a version of the game from January or prior. It shouldn't be able to crash your system, but why you're that out of date is really curious.

On Steam, can you verify your local file cache? Or on GOG, make sure that it's updating you to the latest version? If you're using a downloaded installer from GOG, then please bear in mind those are things that you have to redownload a few times a week to get updates and be on the latest version. It's a really non-ideal situation. If you use GOG Galaxy, that downloads the latest version for you, and there is no DRM and no restrictions. It's just a download vehicle (same with Steam). The files work without any need for internet connection and can be copied elsewhere, but they're kept way more up to date with way less work on your part.

Cheers!

x4000Bughunter

May 8, 2021 3:07 pm

administrator   ~0061427

(Actually, I see that you're on steam, but also that you're on unity 2019.1.7f1 in there, which confirms you are several months out of date. If you're on the 2.715 beta branch, then I'd suggest moving to the current branch.

wen1now

May 11, 2021 2:14 am

reporter   ~0061487

It's possible that I copied the wrong log? I have tried uninstalling and reinstalling the whole game, and I have tried verifying local files. I'm not opted into any beta branch or anything either. I'll take another look when I get back.

x4000Bughunter

May 11, 2021 10:39 am

administrator   ~0061494

The main log for this should be under the game install folder, GameData, and then it's the ArcenDebugLog.txt.

The one from unity that you were copying is likely this one:

~/Library/Logs/Arcen Games, LLC/AIWar2/Player.log

If the game is crashing before it reaches any of our code, then that would match what I'm expecting. But it would still be an old version of the game, and I don't know what the timestamps on there are like (from months ago, or recently). We did upgrade the unity engine, but I don't recall the log file moving along with that. It's always a chance, though.

wen1now

May 12, 2021 9:25 am

reporter   ~0061527

Took a quick look; I couldn't find that file under GameData. There are only four folders -- Configuration, ExternalIcons, ModdableLogicDLLs, and QuickStarts2.

x4000Bughunter

May 12, 2021 9:40 am

administrator   ~0061529

I am so sorry, I said the wrong word! It's under PlayerData.

x4000Bughunter

Jun 4, 2021 8:10 pm

administrator   ~0061965

Marking as not reproducible for now. This was a version of the game that was at least 6 months out of date, so the first step was always going to be getting to the newer version.

Issue History

Date Modified Username Field Change
May 8, 2021 1:42 pm wen1now New Issue
May 8, 2021 3:05 pm x4000Bughunter Note Added: 0061426
May 8, 2021 3:07 pm x4000Bughunter Note Added: 0061427
May 8, 2021 6:30 pm x4000Bughunter Summary launching game causes system crash => launching game causes system crash (very old version on osx opengl)
May 11, 2021 2:14 am wen1now Note Added: 0061487
May 11, 2021 10:39 am x4000Bughunter Note Added: 0061494
May 12, 2021 9:25 am wen1now Note Added: 0061527
May 12, 2021 9:40 am x4000Bughunter Note Added: 0061529
Jun 4, 2021 8:10 pm x4000Bughunter Assigned To => x4000Bughunter
Jun 4, 2021 8:10 pm x4000Bughunter Status new => closed
Jun 4, 2021 8:10 pm x4000Bughunter Resolution open => unable to reproduce
Jun 4, 2021 8:10 pm x4000Bughunter Note Added: 0061965