View Issue Details

IDProjectCategoryLast Update
0023739AI War 2[All Projects] Bug - GameplaySep 22, 2020 2:48 am
ReporterMinotaarAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version2.500 Multiplayer Alpha Begins Now! 
Fixed in VersionBeta 2.506 ExternalData Overhaul Two 
Summary0023739: Exogalactic War units spawning in fairly vanilla game
DescriptionSomething might be off with the player power calculations for the exo war units.

I was playing an 8/8/8 game with only Astro Trains 4 and Dyson Sphere 4 enabled.
The attached save is 3 minutes after the exogalactic units message appeared (5h 47m). The message triggered after I captured the top right corner of the map with a ZPG, Major Data Center, Black Widow Golem and a strikecraft coordinator, I think probably happened right after the Golem was fully repaired (I missed the message during the game so not sure). I was at 219 AIP post reductions, 402 pre reductions. Never did anything with the Dyson, it was AI controlled for the whole game.

The units kept spawning every 6-7 minutes until the end of the game, I think it was only the basic units with around 50 strength each. (The normal waves would be at around 70 strength at this point).

At my power level I had no real problem clearing them (having rams helped immensely), it was more that having to constantly deal with nasty threat units that wreck turret defenses was pretty annoying (even though it added a challenge to a game that was going very well for me at that point). It's sort of like playing with a permanent raid engine in that regard.

I don't think it was intended for these to show up in this type of game, judging by this in the patch notes:
>> Bear in mind that this is not going to be something you would ever see in the average game, and this isn't meant to be a punishment for you doing well or something like that.

Before this I played a 7/7/7 game with 2 AIs and no minor factions on 2.130, and in that game exo war units only started appearing after 1 AI died at 400+ real AIP, with less frequency as well. So maybe this line "Improve the way a player's Overall Power Level is calculated" in 2.133 did it. Or it could be the Dyson's presence, but I feel like it shouldn't be shifting the calculation so massively if it isn't being used by the player.
TagsNo tags attached.

Activities

Minotaar

Sep 14, 2020 8:55 pm

reporter  

exo war start.save (663,881 bytes)

BadgerBadger

Sep 14, 2020 11:01 pm

manager   ~0058518

Hey Chris, I made it possible for a player to trigger extragalactic war units toward the end of regular games like this.

You should weigh on on whether this is something you like, or if they should be even harder to hit.

BadgerBadger

Sep 22, 2020 2:47 am

manager   ~0058610

Last edited: Sep 22, 2020 2:48 am

View 2 revisions

I've made it harder for the player to trigger an exogalactic attack. That said, per discussion with Chris he's okay with having exogalactic units appear for particularly strong players on difficulties >= 7.

The original plan is superseded by (hopefully) more exciting gameplay

Issue History

Date Modified Username Field Change
Sep 14, 2020 8:55 pm Minotaar New Issue
Sep 14, 2020 8:55 pm Minotaar File Added: exo war start.save
Sep 14, 2020 10:59 pm BadgerBadger Assigned To => BadgerBadger
Sep 14, 2020 10:59 pm BadgerBadger Status new => closed
Sep 14, 2020 10:59 pm BadgerBadger Resolution open => fixed
Sep 14, 2020 10:59 pm BadgerBadger Fixed in Version => Beta 2.506 ExternalData Overhaul Two
Sep 14, 2020 11:01 pm BadgerBadger Assigned To BadgerBadger => x4000Bughunter
Sep 14, 2020 11:01 pm BadgerBadger Status closed => assigned
Sep 14, 2020 11:01 pm BadgerBadger Note Added: 0058518
Sep 15, 2020 5:09 am Minotaar Description Updated View Revisions
Sep 22, 2020 2:47 am BadgerBadger Note Added: 0058610
Sep 22, 2020 2:48 am BadgerBadger Note Edited: 0058610 View Revisions
Sep 22, 2020 2:48 am BadgerBadger Assigned To x4000Bughunter => BadgerBadger
Sep 22, 2020 2:48 am BadgerBadger Status assigned => resolved