View Issue Details

IDProjectCategoryLast Update
0022779AI War 2[All Projects] Bug - OtherFeb 12, 2020 11:47 am
ReporterNRSirLimboAssigned Tox4000Bughunter 
Severityminor 
Status closedResolutionno change required 
Product VersionBETA 1.327 Hardened Forcefields 
Fixed in Version 
Summary0022779: XML Modding bug: copy_from does not copy tags
DescriptionI tried something like this:

     <entity name="MetalDistributionNode" copy_from="DistributionNode" icon_overlay="Official/Guardian_Shredder"
            display_name="Metal Distribution Node"
            description="One of the AIs resource hubs. Destroying it will set 10 million units of metal free. Make sure to have enough storage space available!"
            aip_on_death="1"
            science_to_grant_on_death="0"
            hacking_to_grant_on_death="0"
            metal_to_grant_on_death="10000000"
            >
  </entity>

and it never created any of them. I had to add


            tags="DistributionNode,ShowsOnNormalDisplayMode"

to make it work. Maybe this also affects other lists?
TagsNo tags attached.

Activities

BadgerBadger

Feb 12, 2020 11:46 am

manager   ~0055978

This is working as intended. Tags aren't autocopied (this is an intended behaviour).

Issue History

Date Modified Username Field Change
Feb 12, 2020 11:33 am NRSirLimbo New Issue
Feb 12, 2020 11:46 am BadgerBadger Note Added: 0055978
Feb 12, 2020 11:47 am x4000Bughunter Assigned To => x4000Bughunter
Feb 12, 2020 11:47 am x4000Bughunter Status new => closed
Feb 12, 2020 11:47 am x4000Bughunter Resolution open => no change required