View Issue Details

IDProjectCategoryLast Update
0021555AI War 2[All Projects] Balance IssueOct 28, 2019 11:11 pm
ReporterNRSirLimboAssigned ToBadgerBadger 
Severityminor 
Status closedResolutionno change required 
Product Version0.885 The Audible Bodyguard 
Fixed in Version0.888 Astro Examination 
Summary0021555: Zombify Devourer Golem?
DescriptionNot sure if this is intended but right now the player can zombify the Devourer Golem and send it on a rampage through the AI worlds. At first I thought "oh well, this is a balancing problem, having 350 strength points rampaging" but on second thought, why not leave it this way?

If you go through the trouble of killing the Devourer Golem and don't receive metal, science or hacking points (which would be a nice idea too) you ought to get something from it, right? So do what you think is best in this situation.
TagsNo tags attached.

Activities

NRSirLimbo

Aug 31, 2019 10:02 pm

reporter  

20190901032937_1.jpg (508,192 bytes)

arsdor

Sep 1, 2019 5:09 pm

reporter   ~0052733

This would be nice to be left as is!

BadgerBadger

Sep 2, 2019 11:58 pm

manager   ~0052757

I'd be okay with giving a bit of bonus science (1K?) for killing the devourer golem.

Incidentally, the game is supposed to respawn a new devourer golem if the previous one dies. Have you noticed this?

NRSirLimbo

Sep 3, 2019 5:56 am

reporter   ~0052763

Hadn't seen a game yet where I survived long enough for the Golem zombie to die, but I played for a couple of hours after it was killed and never saw a new one. Might be that the zombie is taking up the slot?

RocketAssistedPuffin

Sep 3, 2019 7:25 am

developer   ~0052766

I used debug to kill it in that crazy Nanocaust game I had a while ago, where they were following the Devourer. I don't recall seeing a new one.

BadgerBadger

Sep 9, 2019 7:19 pm

manager   ~0052974

If you can actually zombify the devourer golem then more power to you. If you think this might make a fun Achievement you might open a new ticket to suggest it

jsterrett

Oct 28, 2019 6:53 pm

reporter   ~0054078

Not sure if this is intended, but a zombified Devourer golem will, after a time, become a non-zombified Devourer golem again. (Found this in trying things out after winning the game, which may introduce its own unexpected behaviors.)

To me, that seemed like a bug. However, if it is expected to respawn, then arguably the respawner mechanism also acts to clear its programming.

Either way, I suggest this be made clear to the player.

BadgerBadger

Oct 28, 2019 7:14 pm

manager   ~0054081

well, if you zombify the devourer golem then the game will spawn a new regular Devourer Golem in 10 minutes or so (and the player gets a message about this). Is that what you observe?

I am very surprised to hear that a zombified devourer golem rejoined the Devourer faction.

jsterrett

Oct 28, 2019 11:11 pm

reporter   ~0054089

As far as I could tell, the zombified Devourer disappeared, and the new regular Devourer showed up in its place. This *appeared* to happen when it was warping between systems. I wound up zombifying the Devourer (or *a* Devourer?) twice, and there never seemed to be more than one moving around, though my intel picture was not perfect.

There may have been a message... I did not see one and if there's a message log I don't know how to see it.

Thanks for your time and effort on all of this!

Issue History

Date Modified Username Field Change
Aug 31, 2019 10:02 pm NRSirLimbo New Issue
Aug 31, 2019 10:02 pm NRSirLimbo File Added: 20190901032937_1.jpg
Sep 1, 2019 5:09 pm arsdor Note Added: 0052733
Sep 2, 2019 11:58 pm BadgerBadger Note Added: 0052757
Sep 3, 2019 5:56 am NRSirLimbo Note Added: 0052763
Sep 3, 2019 7:25 am RocketAssistedPuffin Note Added: 0052766
Sep 9, 2019 7:19 pm BadgerBadger Assigned To => BadgerBadger
Sep 9, 2019 7:19 pm BadgerBadger Status new => closed
Sep 9, 2019 7:19 pm BadgerBadger Resolution open => no change required
Sep 9, 2019 7:19 pm BadgerBadger Fixed in Version => 0.888 Astro Examination
Sep 9, 2019 7:19 pm BadgerBadger Note Added: 0052974
Oct 28, 2019 6:53 pm jsterrett Note Added: 0054078
Oct 28, 2019 7:14 pm BadgerBadger Note Added: 0054081
Oct 28, 2019 11:11 pm jsterrett Note Added: 0054089