View Issue Details

IDProjectCategoryLast Update
0021230AI War 2[All Projects] GUISep 9, 2019 4:51 pm
Reporterwm46Assigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBETA 0.861 Strength Of Remains 
Fixed in Version0.888 Astro Examination 
Summary0021230: A tiny section of each button on the sidebar actually selects the option below it
DescriptionSee the video here: https://youtu.be/VSkgNiLrnx0

If the option in question is the bottom most selection of that group, it'll work fine. Each one above it has that spot in the lower half, near the cap display, that links to the option below it.
TagsNo tags attached.

Relationships

related to 0021349 resolvedx4000Bughunter Selection boxes in the Build menu are seriously glitchy 
related to 0021581 resolvedx4000Bughunter UI doesn't always register click on build unit button 

Activities

wm46

Jun 8, 2019 11:10 am

reporter   ~0051897

Just a thought after getting the galaxy map selection bug fixed, maybe it's caused by the metal icon next to the metal cost of the structure? That's the only place where an icon exists on the GUI, and its near the area that is giving issues.

x4000Bughunter

Sep 9, 2019 4:51 pm

administrator   ~0052954

Thanks!

* Fixed several super-annoying glitches with any pieces of text we were using that had icons in them, mainly in parts of the sidebars, where the clickable area of buttons would be absurdly large and obscure part of the button below them. This often led to clicks and hovers actually selecting the wrong button, which was rightly infuriating.
** Turns out this was actually a bug/oversight in TextMeshPro itself, and we've fixed it per the notes we left here: https://forum.unity.com/threads/cant-disable-raycasting-on-tmp-submesh.548500/#post-4948295

Issue History

Date Modified Username Field Change
May 24, 2019 12:37 am wm46 New Issue
Jun 8, 2019 11:10 am wm46 Note Added: 0051897
Sep 8, 2019 10:58 pm wm46 Relationship added related to 0021581
Sep 9, 2019 4:20 am AnnoyingOrange Relationship added related to 0021349
Sep 9, 2019 4:51 pm x4000Bughunter Assigned To => x4000Bughunter
Sep 9, 2019 4:51 pm x4000Bughunter Status new => resolved
Sep 9, 2019 4:51 pm x4000Bughunter Resolution open => fixed
Sep 9, 2019 4:51 pm x4000Bughunter Fixed in Version => 0.888 Astro Examination
Sep 9, 2019 4:51 pm x4000Bughunter Note Added: 0052954