View Issue Details

IDProjectCategoryLast Update
0021209AI War 2[All Projects] Crash/ExceptionMay 17, 2019 9:03 pm
ReporterMckloshivAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBETA 0.859 Lobby Raid 
Fixed in VersionBETA 0.860 The Lobby Ate My Factions?? 
Summary0021209: Enabling trader gets game-breaking exception
DescriptionHere's the exception since it's (relatively) short:
GAAAH! We have a command we need to execute during frame -1 but it's already frame 2024


GameCommand Details:SetupOnly_RequestSetupChanges
  ToBeQueued:False
  FromActualInputEventOfPlayerID:-1
  CameFromMultiplayerClientConnectionIndex:-1
  ExecuteOnFrameNumber:-1
  RelatedString2:CenterColor
  RelatedString3:c007FFF


  at System.Environment.get_StackTrace () [0x00000] in <1f0c1ef1ad524c38bbc5536809c46b48>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, System.Boolean IncludeStackTrace, Arcen.Universal.Verbosity Verbosity) [0x00000] in <daae57fd965b4c99b7b5978c4985087f>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.DebugLogDestination Destination, Arcen.Universal.Verbosity Verbosity) [0x00000] in <daae57fd965b4c99b7b5978c4985087f>:0
  at Arcen.Universal.ArcenDebugging.ArcenDebugLog (System.String Message, Arcen.Universal.Verbosity Verbosity) [0x00000] in <daae57fd965b4c99b7b5978c4985087f>:0
  at Arcen.AIW2.Core.World_AIW2.OnClient_ExecuteGameCommandsReceivedFromServer (Arcen.AIW2.Core.ArcenSimContext Context) [0x00000] in <398f6d7bd0f14fee907a7b0139fb0549>:0
  at Arcen.AIW2.External.SimPlannerImplementation.DoActualSimStep (System.Boolean& stalledWaitingOnConnections, System.Boolean& mayUpdateVisuals) [0x00000] in <3ffecc83c24e447ab8bd0e8e772285c7>:0
  at Arcen.AIW2.Core.Engine_AIW2.ProcessSimStep (System.Boolean& stalledWaitingOnConnections) [0x00000] in <398f6d7bd0f14fee907a7b0139fb0549>:0
  at Arcen.Universal.Engine_Universal.OnUpdateFromMainThread () [0x00000] in <daae57fd965b4c99b7b5978c4985087f>:0
  at ArcenGameController.Update () [0x00000] in <03f6f117f10f4b26a85c658813aeb19b>:0
TagsNo tags attached.

Activities

x4000Bughunter

May 16, 2019 9:47 am

administrator   ~0051618

This is a super duper strange error. Is this is something that you can routinely recreate?

Basically what is happening here is that it isn't giving the proper data on "do this command soon," but rather is stating to do the command in the past. That is... bizarre. The other errors in the lobby that I'm seeing make sense, but this one I can't duplicate and seems to be some sort of gremlin that exists outside of the lobby, anyway (occasionally people have been seeing this during gameplay).

Any info you have on how to repro this would be welcome, but I'll look into a few things in the meantime that might help.

BadgerBadger

May 16, 2019 10:00 am

manager   ~0051620

I started a game with the zenith trader and let it go for 10 minutes without seeing this. It also doesn't trigger on the Zenith Trader being at one of your planets, or buying something from the Trader.

x4000Bughunter

May 16, 2019 10:05 am

administrator   ~0051623

This was something during the lobby itself, I can see because it says "SetupOnly_RequestSetupChanges". Basically when he made the selection in the dropdown it died immediately then trying to tell the game what the dropdown asked for. I doubt it's related to the Zenith Trader specifically.

BadgerBadger

May 16, 2019 10:09 am

manager   ~0051624

But the error didn't happen till after the game started, right? Since the game is at frame 2024?

x4000Bughunter

May 16, 2019 10:46 am

administrator   ~0051632

I have put in this code for the next build:

* In the event that for some reason the game tries to queue a GameCommand with an ExecuteOnFrameNumber of -1 (this seems to happen from time to time during the game and now once in the lobby), it will complain at the time of it trying to queue it, and give a stack trace from there, and not actually do the queuing of it.
** This should help us figure out when and why these things are occasionally happening. It's probably related to a pooling error of some sort, but it's hard to be sure. If the commands are valid at this point and then later have ExecuteOnFrameNumber of -1 when being read back, then we know we have a different problem entirely and can approach that from another way. Either way we'll start having more info soon on this rare and elusive error.

x4000Bughunter

May 16, 2019 10:48 am

administrator   ~0051633

"But the error didn't happen till after the game started, right? Since the game is at frame 2024?"

Actually, during the lobby it runs frames as if the game was running. Even when the game is paused, it runs frames. It's not running sim steps DURING those frames, but the host and any clients are communicating back and forth in an ordered fashion. So this is definitely still during the lobby. Or the command got REALLY delayed and that's a whole other issue, but nothing in the stack trace makes me think that was the case.

Mckloshiv

May 16, 2019 4:34 pm

reporter   ~0051637

I am unable to find a way to reproduce it on my end (and in the lobby). I suppose I named the thread wrong since it does not seem to directly be caused by the Zenith Trader.

x4000Bughunter

May 17, 2019 9:03 pm

administrator   ~0051680

No worries! It should be fixed now, or at least give us real info next time. Thanks!

Issue History

Date Modified Username Field Change
May 15, 2019 5:51 pm Mckloshiv New Issue
May 16, 2019 9:47 am x4000Bughunter Note Added: 0051618
May 16, 2019 10:00 am BadgerBadger Note Added: 0051620
May 16, 2019 10:05 am x4000Bughunter Note Added: 0051623
May 16, 2019 10:09 am BadgerBadger Note Added: 0051624
May 16, 2019 10:46 am x4000Bughunter Note Added: 0051632
May 16, 2019 10:46 am x4000Bughunter Assigned To => x4000Bughunter
May 16, 2019 10:46 am x4000Bughunter Status new => feedback
May 16, 2019 10:48 am x4000Bughunter Note Added: 0051633
May 16, 2019 4:34 pm Mckloshiv Note Added: 0051637
May 16, 2019 4:34 pm Mckloshiv Status feedback => assigned
May 17, 2019 9:03 pm x4000Bughunter Status assigned => resolved
May 17, 2019 9:03 pm x4000Bughunter Resolution open => fixed
May 17, 2019 9:03 pm x4000Bughunter Fixed in Version => BETA 0.860 The Lobby Ate My Factions??
May 17, 2019 9:03 pm x4000Bughunter Note Added: 0051680