View Issue Details

IDProjectCategoryLast Update
0021169AI War 2[All Projects] Bug - GameplayMay 13, 2019 6:11 pm
ReporterRocketAssistedPuffinAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product VersionBETA 0.856 Clever Girl 
Fixed in VersionBETA 0.859 Lobby Raid 
Summary0021169: Singular Freaky Surprises has a strange error
DescriptionNot sure how to explain it in the title.

Golemite is meant to have 100 tickets for a planet to have nothing, and 60 tickets for it to have a Golem.

In reality, sometimes with the Golemite, not a single one will appear. Other times, every planet (including the ones next to your Homeworld) will have Golems.

It seems to be a chance per galaxy, instead of per planet?

I can change the ticket counts for non-Golemite AIs, and can get them to do the same behaviour.
TagsNo tags attached.

Activities

wm46

May 9, 2019 12:55 am

reporter   ~0051553

The issue is fairly simple (I say after I spend 2 hours studying what the hell drawbags are and how they work in the code).

Fixed it just by putting this section of code at AI.cs - Line 198:

            AIShipGroup groupFromCategory = ShipGroupCategory.DrawBag.PickRandomItemAndReplace( Context.RandomToUse );
            if ( groupFromCategory == null || groupFromCategory.DrawBag.InternalListSize <= 0 )
                return; //this is ok, too!

Into the for loop that selects the ship for the planet. That bit of code selects which category to seed (Golem / Nothing / SomethingElse), and the for loop selects the ship from the category. Now each loop instead of picking another ship from the same category, it'll randomize the category and then pick a ship.

I wonder if this is also an issue with waves, as they sometimes feel too homogeneous even though I select varied waves each time. It makes even the Parasite AI seem weak because it can send waves of thousands of parasite ships (that do like 5 dps each).

wm46

May 9, 2019 2:19 am

reporter   ~0051556

I see how waves end up with very limited amounts of ship types now. The wave planner gives up on picking ship types after the first bag it picked runs out of ships, even if the wave was supposed to have 8 ship types.

I could change it, but I'm pretty sure Chris's vision for waves is to have them be thematic (the parasite wave, the sniper wave, etc). So I guess I'll leave it be on that front. Something I'd be interested in doing is finding a way for the wave to add in 0, 1, 2 guardians to the mix again. None of the ship groups seem to have any guardians in them.

RocketAssistedPuffin

May 9, 2019 6:58 am

developer   ~0051557

The waves are intended to be thematic, yes.

Guardians were intentionally removed from waves. Only the Royal AI can send them in waves.

BadgerBadger

May 12, 2019 7:54 pm

manager   ~0051589

Is this fixed now? I seem to remember a checkin from WeaponMaster on this subject

wm46

May 12, 2019 10:15 pm

reporter   ~0051591

Yeah I fixed it. Singular surprises now get rolled per planet rather than per galaxy.

BadgerBadger

May 13, 2019 10:05 am

manager   ~0051592

Fixed by weapon master

RocketAssistedPuffin

May 13, 2019 11:23 am

developer   ~0051593

Last edited: May 13, 2019 6:11 pm

View 2 revisions

Something still seems wrong with it.

I can put the ticket count of Golems for the Golemite up to 900 (100 for NothingHere) and the galaxy is mostly devoid, and what Golems that do spawn are all around the player Homeworld in every test.

Regarding Guardians - I don't think I like that. It feels weird to have thematic waves, then because it rolled a high number of ship types, bring in 2-3 different Guardian groups. Waves used to be a bit messy, and I worry this might do it again.

It brings back the chance of Temperamentals and Fragmentings to spawn in offensive attacks as well, looking at the code. They were specifically limited to AI planets only, because you can't stop them from triggering on the offensive.

Issue History

Date Modified Username Field Change
May 1, 2019 11:53 am RocketAssistedPuffin New Issue
May 9, 2019 12:55 am wm46 Note Added: 0051553
May 9, 2019 2:19 am wm46 Note Added: 0051556
May 9, 2019 6:58 am RocketAssistedPuffin Note Added: 0051557
May 12, 2019 7:54 pm BadgerBadger Note Added: 0051589
May 12, 2019 10:15 pm wm46 Note Added: 0051591
May 13, 2019 10:05 am BadgerBadger Assigned To => BadgerBadger
May 13, 2019 10:05 am BadgerBadger Status new => resolved
May 13, 2019 10:05 am BadgerBadger Resolution open => fixed
May 13, 2019 10:05 am BadgerBadger Fixed in Version => BETA 0.859 Lobby Raid
May 13, 2019 10:05 am BadgerBadger Note Added: 0051592
May 13, 2019 11:23 am RocketAssistedPuffin Note Added: 0051593
May 13, 2019 6:11 pm RocketAssistedPuffin Note Edited: 0051593 View Revisions