View Issue Details

IDProjectCategoryLast Update
0021165AI War 2[All Projects] Bug - GameplayMay 16, 2019 3:54 pm
ReportervincoAssigned Tox4000Bughunter 
Severitymajor 
Status resolvedResolutionfixed 
Product VersionBETA 0.855 Galactic Markings 
Fixed in VersionBETA 0.860 The Lobby Ate My Factions?? 
Summary0021165: Cannot add additional factions
DescriptionIn the lobby, I can't add any additional factions. I select one, it moves to the top slot under the AI, then it vanishes. It's happened for every faction I've tried to add.
TagsNo tags attached.

Relationships

related to 0021149 resolvedx4000Bughunter Can't enable multiple minor factions in game lobby 

Activities

x4000Bughunter

May 15, 2019 4:38 pm

administrator   ~0051604

Fixed in the next build, thanks!

Ovalcircle

May 15, 2019 6:46 pm

reporter   ~0051610

Actually this is not fixed as of 0.859, t least for me. The only faction I can reliably enable is the AI Risk analyzers. If I try to add anything else, the faction list gets reset or I get an error with the Devourer Golem or Zenith Trader.

BadgerBadger

May 16, 2019 12:53 am

manager   ~0051611

Last edited: May 16, 2019 12:54 am

View 2 revisions

I can confirm this is not fixed. If I enter a lobby with 2 AIs enabled, then enable the Risk Analyzers in the first open faction spot, it works. If I then put the Dark Spire in the second open faction spot then it resets the factions.

That's not the only scenario; for example, I can't enable the Dyson Sphere at all.

x4000Bughunter

May 16, 2019 9:44 am

administrator   ~0051617

Got it; I had tested a few variants of this and it seemed fixed, but it's definitely not and I can (thankfully!) duplicate it. I was worried that this was something that was limited to just the release build somehow, but it's not.

x4000Bughunter

May 16, 2019 3:54 pm

administrator   ~0051635

Thanks!

* Some changes have been made to make the dropdown selection changes more synchronous (instant) rather than on a slight time delay. This allows for a few things to be controlled a bit better... in theory.

* Wow, a whole heck of a lot of wrappering and rework has been done on dropdowns to make it more clear when and how data is being set.
** We were actually still having the same problem with factions getting erased as soon as they were added in the prior build, along with some other known issues like dropdown stuff getting out of sync quickly that we did know about.
** All of this is traceable back to how the dropdowns handle data updates to themselves, and it's another question of "how did this ever work?" This one was a Chris area, not a Keith one, just in case anyone gets the wrong idea that any of the early code problems were all from one source (far from it).
** Issues fixed:
*** still couldn't add more factions
*** setup is being triggered when clicking to the factions tab, still, probably because the intermediate data is incorrectly populated
*** opening the MORE button for a factions tab still does a regeneration, probably because the intermediate data is incorrectly populated
** Remaining known issues:
*** the colors for the player are out of sync between the dropdowns and the visual display area VISUALLY, even though the underlying data is now correct.
*** custom data can be stale when switching map types in the lobby, although it's not causing errors per se.

Issue History

Date Modified Username Field Change
Apr 30, 2019 11:38 pm vinco New Issue
May 1, 2019 10:25 am BadgerBadger Relationship added related to 0021149
May 15, 2019 4:38 pm x4000Bughunter Assigned To => x4000Bughunter
May 15, 2019 4:38 pm x4000Bughunter Status new => resolved
May 15, 2019 4:38 pm x4000Bughunter Resolution open => fixed
May 15, 2019 4:38 pm x4000Bughunter Fixed in Version => BETA 0.859 Lobby Raid
May 15, 2019 4:38 pm x4000Bughunter Note Added: 0051604
May 15, 2019 6:46 pm Ovalcircle Note Added: 0051610
May 16, 2019 12:53 am BadgerBadger Status resolved => assigned
May 16, 2019 12:53 am BadgerBadger Note Added: 0051611
May 16, 2019 12:54 am BadgerBadger Note Edited: 0051611 View Revisions
May 16, 2019 9:44 am x4000Bughunter Note Added: 0051617
May 16, 2019 3:54 pm x4000Bughunter Status assigned => resolved
May 16, 2019 3:54 pm x4000Bughunter Fixed in Version BETA 0.859 Lobby Raid => BETA 0.860 The Lobby Ate My Factions??
May 16, 2019 3:54 pm x4000Bughunter Note Added: 0051635