View Issue Details

IDProjectCategoryLast Update
0020865AI War 2[All Projects] Bug - GameplayDec 23, 2018 5:28 am
ReporterKahunaAssigned To 
Status newResolutionopen 
Product Version0.809 Divide By Human 
Fixed in Version 
Summary0020865: Pause induced rubberbanding
DescriptionAt the moment pausing sometimes causes weird rubberbanding and behavior when ordering ships.

Steps to reproduce
-Have 10 scouts on one stack/blob.
-Pause the game.
-Order the 10 scouts to move to another location nearby.
-Quickly unpause and pause the game again.
-Press L to select half of the selected scouts (5).
-Order the selected 5 scouts to move to another location nearby.
-Watch as the scouts rubberband and the ones selected by pressing L don't go to the ordered location.
TagsNo tags attached.



Dec 23, 2018 3:40 am


Game (1,062,389 bytes)
20181223102807_1.jpg (737,592 bytes)


Dec 23, 2018 3:57 am

reporter   ~0050649

@Kahuna -- I just tried to replicate this in my game following the (very clearly written, thank you!) step by step instructions you provided... but I wasn't able to replicate it. In my tests after setting the 10 scouts to move while paused, quickly un-pausing & re-pausing, pressing L to select half, ordering those to a different location, and un-pausing... the first 5 continues to the original move order and the second 5 split off go toward the second move order as expected. I haven't tried loading up your save yet though. I wonder what's different on yours?


Dec 23, 2018 4:09 am

reporter   ~0050650

@nomad_delta Interesting. I have tried this dozens of times and tried again and it happens every time.

20181223110715_1.jpg (614,719 bytes)


Dec 23, 2018 4:14 am

reporter   ~0050651

This isn't save file specific since I made a new game and it still happens.

Some time ago when I started AI War 2 it used to ask if I want to use DirectX10 or something else. Or something like that. I don't remember which setting I chose but perhaps it could have something to do with this. No idea. Just throwing this out here.


Dec 23, 2018 5:21 am

reporter   ~0050655

@Kahuna -- hmm didn't get any messages about DirectX here during install or when launching. I've installed via Steam on a Windows 10 box, in case your install might be different somehow. Another possibility -- are you using any of the game speed up/down options? I've mostly left mine at the defaults, but I've seen a few bug reports from other people getting weird behavior when cranking the game speed up really high (like 10x). I'll let you know if I end up replicating or seeing this at some point.


Dec 23, 2018 5:28 am

reporter   ~0050656

@nomad_delta I think AIW2 was still in beta when I got the DirectX message. The message had steam colors and user interface and came before the game process started after double clicking the icon on desktop or starting the game from Steam. Don't remeber which option I chose and don't know if that choice has any effect anymore.

And no I didn't use any speed up nor down options. The game was on default speed.

Issue History

Date Modified Username Field Change
Dec 23, 2018 3:40 am Kahuna New Issue
Dec 23, 2018 3:40 am Kahuna File Added: 20181223102807_1.jpg
Dec 23, 2018 3:40 am Kahuna File Added: Game
Dec 23, 2018 3:57 am nomad_delta Note Added: 0050649
Dec 23, 2018 4:09 am Kahuna File Added: 20181223110715_1.jpg
Dec 23, 2018 4:09 am Kahuna Note Added: 0050650
Dec 23, 2018 4:14 am Kahuna Note Added: 0050651
Dec 23, 2018 5:21 am nomad_delta Note Added: 0050655
Dec 23, 2018 5:28 am Kahuna Note Added: 0050656