View Issue Details

IDProjectCategoryLast Update
0020769AI War 2[All Projects] Bug - GameplayJan 9, 2019 7:55 am
ReporterAnnoyingOrangeAssigned ToBadgerBadger 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.806 Sabre Company 
Fixed in Version0.810 Brace for Cross Planet Attack 
Summary0020769: Ships warping to incorrect position after wormhole
DescriptionSometimes, when sending ships through a wormhole some of the ships will appear at the target system but far from the selected wormhole, usually near the opposite end of the system.
This is most noticeable when sending through large amounts of ships, but I had it happen a few times also when sending through a single ship (one artillery golem) or a small fleet (4 raid starships).
Attached is a save file soon after the bug happening on the planet Hearth, in which a couple of Vampire Claws warped incorrectly.
TagsNo tags attached.

Relationships

related to 0020397 resolvedBadgerBadger Ship icons appearing and disappearing in the middle of the planet 
related to 0020665 resolvedBadgerBadger When moving through a wormhole while paused, some ships appear on random places in the target system 
related to 0020871 resolvedBadgerBadger Ships teleport to a far away location when going through a wormhole 

Activities

AnnoyingOrange

Nov 11, 2018 8:16 am

reporter  

Mainline.savemet (55 bytes)
Mainline.save (1,160,465 bytes)

AnnoyingOrange

Nov 14, 2018 9:40 am

reporter   ~0050479

In addition, the "wrong warp" behaviour appears to be somewhat deterministic: reloading a save seems to produce the same result if the same ship is sent through, even if one first queues up a few move orders.
I'll try and create a save file that shows such behaviour.

AnnoyingOrange

Dec 10, 2018 9:51 am

reporter   ~0050594

I managed to create a save in which a specific unit sometimes warps incorrectly: on planet Sancere in the bottom part of the map, there is an artillery golem with an order to go through the wormhole to the adjacent planet Congo.
Unfortunately, the issue is not very consistent.

1.save (618,161 bytes)
1.savemet (46 bytes)

RocketAssistedPuffin

Jan 9, 2019 7:55 am

developer   ~0050710

Appears to be fixed by Badger now - ludicrous testing cases to exaggerate it comes up with no incidents.

Issue History

Date Modified Username Field Change
Nov 11, 2018 8:16 am AnnoyingOrange New Issue
Nov 11, 2018 8:16 am AnnoyingOrange File Added: Mainline.savemet
Nov 11, 2018 8:16 am AnnoyingOrange File Added: Mainline.save
Nov 13, 2018 10:40 am Dune Relationship added related to 0020397
Nov 13, 2018 10:41 am Dune Relationship added related to 0020665
Nov 13, 2018 10:41 am Dune Assigned To => x4000Bughunter
Nov 13, 2018 10:41 am Dune Status new => assigned
Nov 14, 2018 9:40 am AnnoyingOrange Note Added: 0050479
Dec 10, 2018 9:51 am AnnoyingOrange File Added: 1.savemet
Dec 10, 2018 9:51 am AnnoyingOrange File Added: 1.save
Dec 10, 2018 9:51 am AnnoyingOrange Note Added: 0050594
Dec 29, 2018 2:20 pm Dune Relationship added related to 0020871
Jan 9, 2019 7:55 am RocketAssistedPuffin Assigned To x4000Bughunter => BadgerBadger
Jan 9, 2019 7:55 am RocketAssistedPuffin Status assigned => resolved
Jan 9, 2019 7:55 am RocketAssistedPuffin Resolution open => fixed
Jan 9, 2019 7:55 am RocketAssistedPuffin Fixed in Version => 0.810 Brace for Cross Planet Attack
Jan 9, 2019 7:55 am RocketAssistedPuffin Note Added: 0050710