View Issue Details

IDProjectCategoryLast Update
0020668AI War 2[All Projects] Bug - GameplayMar 20, 2019 6:10 pm
Reporterxjxxjx1017Assigned Tox4000Bughunter 
Severitymajor 
Status closedResolutionfixed 
Product Version0.804 Hack Me Quickly 
Fixed in VersionBETA 0.850 The Arrival of Fleets 
Summary0020668: assign rally to control group for a dock influence the other dock on another planet
DescriptionI'm not sure whether it's duplicated, but...

Currently I have control group 1,2,3 active.
control group 1 is acting as my offense team.
control group 2 is acting as my defense team.

Assign one rally to control group 1, for a dock listed as the first shipyard on a planet, will also change the rally setting on another planet to rally to control group 1.
The same if I change rally for a different shipyard or on a different planet or for a different control group.

I remember it was working fine at a point, but I've been deleting shipyards, which might be the cause of the issue.

It makes it very hard to use rally to control group from this point.
TagsNo tags attached.

Activities

xjxxjx1017

Oct 21, 2018 6:36 pm

reporter  

Bug.assign one ally to control group for a dock influence the other one on another galaxy.zip (140,940 bytes)

Dune

Oct 23, 2018 11:31 am

administrator   ~0050259

Thank you for the feedback. Can you confirm if this happens if the game is saved and then restarted?

xjxxjx1017

Oct 23, 2018 4:01 pm

reporter   ~0050272

I kind of remember that I thought it might be a run-time bug and try reloading the game, but didn't get rid of it. I'll try it again later.
I've attached a save file on my last note.

xjxxjx1017

Oct 24, 2018 2:02 am

reporter   ~0050298

Confirmed it's still there after restart.

Dune

Oct 24, 2018 9:25 am

administrator   ~0050302

Excellent. Thank you.

RocketAssistedPuffin

Mar 20, 2019 6:10 pm

developer   ~0051011

Closing because of the changes to Docks and Control Groups in 0.900. Don't think this'll be relevant.

Issue History

Date Modified Username Field Change
Oct 21, 2018 6:36 pm xjxxjx1017 New Issue
Oct 21, 2018 6:36 pm xjxxjx1017 File Added: Bug.assign one ally to control group for a dock influence the other one on another galaxy.zip
Oct 21, 2018 6:36 pm xjxxjx1017 Summary assign one ally to control group for a dock influence the other one on another galaxy => assign one ally to control group for a dock influence the other one on another planet
Oct 21, 2018 6:48 pm xjxxjx1017 Summary assign one ally to control group for a dock influence the other one on another planet => assign one rally to control group for a dock influence the other one on another planet
Oct 21, 2018 6:49 pm xjxxjx1017 Summary assign one rally to control group for a dock influence the other one on another planet => assign rally to control group for a dock influence the other dock on another planet
Oct 23, 2018 11:31 am Dune Assigned To => x4000Bughunter
Oct 23, 2018 11:31 am Dune Status new => assigned
Oct 23, 2018 11:31 am Dune Note Added: 0050259
Oct 23, 2018 4:01 pm xjxxjx1017 Note Added: 0050272
Oct 24, 2018 2:02 am xjxxjx1017 Note Added: 0050298
Oct 24, 2018 9:25 am Dune Note Added: 0050302
Mar 20, 2019 6:10 pm RocketAssistedPuffin Status assigned => closed
Mar 20, 2019 6:10 pm RocketAssistedPuffin Resolution open => fixed
Mar 20, 2019 6:10 pm RocketAssistedPuffin Fixed in Version => BETA 0.850 The Arrival of Fleets
Mar 20, 2019 6:10 pm RocketAssistedPuffin Note Added: 0051011