View Issue Details

IDProjectCategoryLast Update
0020494AI War 2[All Projects] Gameplay IssueDec 27, 2018 6:33 pm
ReporterRocketAssistedPuffinAssigned Tox4000Bughunter 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.782 Viewport Visibility 
Fixed in Version0.810 
Summary0020494: Targeting errors of things like Spider units
DescriptionSave has some Spider Turrets focusing all their shots onto a couple of units instead of spreading out the engine damage. Likely on every other unit with a debuff of some kind.

Dunno what else to say.

TagsNo tags attached.

Activities

RocketAssistedPuffin

Oct 12, 2018 8:49 pm

developer  

SpiderTurretTarget.save (749,856 bytes)

RocketAssistedPuffin

Dec 27, 2018 5:49 pm

developer   ~0050676

Several months later I have something to add: This targeting error of never spreading out the effect only occurs...if the unit can't move.

Spider Fleetships? Perfectly spreads it out!

Spider Turret? Nope, doesn't at all.

Make the Turret able to move? Suddenly it works perfectly!

Changing the range, engine stun, giving it multishot, giving it the same weapon as the Fleetship, changing the priority, behaviour...none of it worked.

But strapping engines to it does.

I don't understand life anymore.

RocketAssistedPuffin

Dec 27, 2018 6:33 pm

developer   ~0050677

This appears to fix Spider Turrets not spreading out their slow effect.

'int amountICanStunHim = AttackerSystem.GetEngineStunAgainst( AttackerEntity );

It was checking itself to see if it could stun a target. Mobile ships worked fine, as often they could stun themselves, but turrets can't, and so defaulted to simple damage dealing since "there's no stunnable targets!" regardless of what there was.

Changing it to DefenderEntity has produced no errors whatsoever, and makes them finally work as intended!

Issue History

Date Modified Username Field Change
Oct 12, 2018 8:49 pm RocketAssistedPuffin New Issue
Oct 12, 2018 8:49 pm RocketAssistedPuffin File Added: SpiderTurretTarget.save
Oct 24, 2018 2:48 pm Dune Assigned To => x4000Bughunter
Oct 24, 2018 2:48 pm Dune Status new => assigned
Dec 27, 2018 5:49 pm RocketAssistedPuffin Note Added: 0050676
Dec 27, 2018 6:33 pm RocketAssistedPuffin Status assigned => resolved
Dec 27, 2018 6:33 pm RocketAssistedPuffin Resolution open => fixed
Dec 27, 2018 6:33 pm RocketAssistedPuffin Fixed in Version => 0.810
Dec 27, 2018 6:33 pm RocketAssistedPuffin Note Added: 0050677