View Issue Details

IDProjectCategoryLast Update
0019042AI War 2[All Projects] Bug - GameplayApr 25, 2017 2:09 pm
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severitymajor 
Status resolvedResolutionfixed 
Product Version0.110 and 0.111 Modding Overhaul And Unity Upgrade 
Fixed in Version 
Summary0019042: Multiplayer gets completely out of sync
DescriptionI started a multiplayer game. My desktop (linux) hosted, and my laptop (osx) connected to it. I still see a significant lag (5-10 seconds) between any clicks on my laptop and having the units move, but there's a different mantis bug tracking that.

However, much worse than that is that the games are totally out of sync. My desktop never sees anything that the laptop does, and visa versa. I'm uploading 2 pictures, one from my desktop's POV and one from my laptop's. I took the picture seconds apart.

Two more minor quibbled. Both games start with the screen zoomed in on the orange ark. I think the laptop (controlling the purple ark) should start zoomed in on that to make it clear which ark is mine.
Also, when my laptop (purple) captures a planet, it gets an orange controller symbol instead of a purple controller symbol, and the controller can't be used.
TagsNo tags attached.

Activities

BadgerBadger

Mar 14, 2017 12:38 pm

reporter  

desktop_screenshot.png (2,013,330 bytes)

BadgerBadger

Mar 14, 2017 12:40 pm

reporter   ~0045992

Last edited: Mar 14, 2017 12:54 pm

View 3 revisions

Whoops, I can't attach the laptop image because Mantis won't let me (too large of files I guess). I can try to reduce the size of the picture, or you can try to reproduce locally, let me know what you'd like. On the laptop, what you see is the Orange fleet blob chilling on the side of the gravity well, the purple ships are near the controller, and all the green units are gone.

I can also open separate bug reports for the two minor quibbles I had.

There are no errors reported in the logs in PlayerData

BadgerBadger

Mar 18, 2017 1:31 pm

reporter   ~0046015

I am unable to reproduce the larger problem (AI War desynced) on .113. My other quibbles are still there though, but I'll open a seperate mantis bug

BadgerBadger

Mar 22, 2017 9:51 am

reporter   ~0046020

I will try this again on .114 when that comes out, and if I can't reproduce again then lets close this bug.

BadgerBadger

Apr 18, 2017 7:42 pm

reporter   ~0046058

This problem no longer reproduces; I just tried on .118. Feel free to close this bug.

keith.lamothe

Apr 25, 2017 2:09 pm

administrator   ~0046081

Thanks :)

Issue History

Date Modified Username Field Change
Mar 14, 2017 12:38 pm BadgerBadger New Issue
Mar 14, 2017 12:38 pm BadgerBadger File Added: desktop_screenshot.png
Mar 14, 2017 12:40 pm BadgerBadger Note Added: 0045992
Mar 14, 2017 12:53 pm BadgerBadger Note Edited: 0045992 View Revisions
Mar 14, 2017 12:54 pm BadgerBadger Note Edited: 0045992 View Revisions
Mar 18, 2017 10:53 am x4000Bughunter Assigned To => Cath
Mar 18, 2017 10:53 am x4000Bughunter Status new => assigned
Mar 18, 2017 1:31 pm BadgerBadger Note Added: 0046015
Mar 21, 2017 5:26 pm x4000Bughunter Assigned To Cath => keith.lamothe
Mar 22, 2017 9:51 am BadgerBadger Note Added: 0046020
Apr 18, 2017 7:42 pm BadgerBadger Note Added: 0046058
Apr 25, 2017 2:09 pm keith.lamothe Note Added: 0046081
Apr 25, 2017 2:09 pm keith.lamothe Status assigned => resolved
Apr 25, 2017 2:09 pm keith.lamothe Resolution open => fixed