Arcen Idea Tracker (Bugs and Features)

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryDate SubmittedLast Update
0019039AI War 2[All Projects] Crash/ExceptionMar 11, 2017 1:46 amMar 14, 2017 7:22 pm
Reportertreyra 
Assigned Tox4000Bughunter 
Severitymajor 
StatusresolvedResolutionfixed 
Product Version0.109 Special Forces And Modding 
Fixed in Version0.112 Plasma, Forcefields, and DirectX11 
Summary0019039: Crashes within a minute
DescriptionI have yet to get .109 to last for more than a minute without crashing. I reinstalled the files and validated them, but the problem persists. I can't find a generated crash log though, so I can't narrow the problem down.
TagsNo tags attached.
Attached Filestxt file icon output_log.txt [^] (31,453 bytes) Mar 13, 2017 3:43 pm [Show Content]
txt file icon output_log2.txt [^] (31,452 bytes) Mar 13, 2017 4:16 pm [Show Content]
png file icon Crash.png [^] (1,048,934 bytes) Mar 13, 2017 4:17 pm
txt file icon output_log3.txt [^] (31,449 bytes) Mar 13, 2017 4:44 pm [Show Content]
txt file icon output_log4.txt [^] (28,763 bytes) Mar 13, 2017 4:45 pm [Show Content]
txt file icon output_log5.txt [^] (31,450 bytes) Mar 13, 2017 4:45 pm [Show Content]
txt file icon output_log6.txt [^] (25,402 bytes) Mar 13, 2017 5:46 pm [Show Content]
txt file icon output_log7.txt [^] (30,570 bytes) Mar 14, 2017 3:27 pm [Show Content]
txt file icon output_log8.txt [^] (29,357 bytes) Mar 14, 2017 3:27 pm [Show Content]
txt file icon output_log9.txt [^] (31,450 bytes) Mar 14, 2017 3:38 pm [Show Content]
txt file icon output_log10.txt [^] (31,116 bytes) Mar 14, 2017 3:38 pm [Show Content]

- Relationships
related to 0019041closedx4000Bughunter Game won't launch 

-  Notes
(0045961)
BadgerBadger (reporter)
Mar 11, 2017 11:33 am

Which OS are you running? Does it look like similar symptoms to 19028? Do you have errors in the Unity log? Chris gave instructions to finding the unity log in the other bug
(0045963)
treyra (reporter)
Mar 11, 2017 2:51 pm
edited on: Mar 11, 2017 2:59 pm

Oh thanks for reminding me BadgerBadger.

OS: Windows 10
Graphics: GTX 960m

I couldn't find that file path, "~/.config/unity3d/CompanyName/ProductName/Player.log" right?

I do see the ArcenDebugLog.txt and ErrorsReportedByEngine.txt, but neither has an exception since 2/27, despite numerous crashes since then.

I would say the symptoms are fairly different, since it seems almost like a matter of time before crashing. It will crash in the main menu, the galaxy chooser or midway through the first battle, but I haven't got it anywhere past that.

(0045966)
x4000Bughunter (administrator)
Mar 13, 2017 10:30 am

On windows, that file path is in your AIWar2_Data subfolder, or AIWar2_64_Data subfolder, and is just output.log.

What happens when it crashes? Does the program simply exit?

Are you running the DX9 or the OpenGLCore version through Steam?

Think there's any chance that the crash is happening on song change in the music?
(0045970)
treyra (reporter)
Mar 13, 2017 3:46 pm

Okay I see that file, thank you. I've attached it here. When it crashes, the GUI stops responding but the music continues, and further attempts to click in the game cause the blue spinning wheel to appear and windows to prompt that it is not responding (I have not seen a music change associated with it but I wasn't looking).

This was running both the DX9 and OpenGLCore version (to see if one or the other worked)

I'm going to see if I can reproduce it in today's build.
(0045971)
treyra (reporter)
Mar 13, 2017 4:02 pm

Well I can't get the new build to launch at all, so that's a different problem (0019041).
(0045974)
treyra (reporter)
Mar 13, 2017 4:19 pm

So I got the new build to launch after all, and reproduced the issue. Two crashes occurred, one at 1:20 into the game and another at 1:45 into the game. The music did not change at either time. I was trying to see if any of my actions might be causing it (hence why the screen shot is super zoomed in), but since nothing was consistent (the first time I had just given an order, the second just zoomed way in), I don't think user input is the source. I also uploaded a log for the second crash (log2).
(0045975)
x4000Bughunter (administrator)
Mar 13, 2017 4:19 pm

Okay, so now this does still run, but with this same problem, as you noted from 0019041.
(0045977)
treyra (reporter)
Mar 13, 2017 4:22 pm

Yep, the build runs and feels the same as .109

Still crashing within a minute or two of launch.
(0045978)
x4000Bughunter (administrator)
Mar 13, 2017 4:22 pm

Couple of things to maybe try. I notice that you've already edited the settings files, so that shouldn't be any new thing.

Can you try putting it back in windowed mode instead of fullscreen? And then can you also set DisableMusic to true? I'd be very curious to know if either one of those changes solves the problem -- that would at least point me in the direction of what is wrong.

Thanks!
Chris
(0045979)
treyra (reporter)
Mar 13, 2017 4:37 pm

Tried the windowing first, still ran into a problem. I will now try both that and the music off together.
(0045980)
treyra (reporter)
Mar 13, 2017 4:44 pm

Okay, still crashing. The first try with the music off crashed as soon as I hit new game from the main menu.

I now think it might be related to user input, as I left the last attempt alone for a minute, came back and nudged the camera, and that caused the crash.

More logs (if desired) 3 = windowed with music 4 = windowed w/o music, fast crash 5 = windowed w/o music slower crash.
(0045981)
treyra (reporter)
Mar 13, 2017 4:52 pm

And this has all been in OpenGL for the latest build.
(0045982)
x4000Bughunter (administrator)
Mar 13, 2017 5:00 pm

Okay! That is a whole lot of very helpful feedback.

I am presently thinking that this might be a problem with xinput. Out of curiosity, do you have any unusual input devices connected? Flight stick, etc?

There a couple of potential ways around this. The simplest thing to test is if you go into AIWar2_x64_Data/Managed and then delete the file Rewired_Windows_Lib.dll. Be sure NOT to delete Rewired_Core.dll or the whole thing will barf and die. ;)

Once you run that, then your output_log.txt files should no longer contain the text "Rewired: Found Xinput1_3.dll". If that's not in there, then we know it's working properly and just sitting on top of unity's default input handling rather than trying to use xinput.

If XInput is the culprit, then we'll just stop using that. It's pretty well overkill at the moment anyhow, and we might be able to shave off a tad of performance by doing that anyway.

Thanks!
(0045983)
treyra (reporter)
Mar 13, 2017 5:46 pm

I do have a xbox controller dongle plugged in, although the controller itself is off. To be sure I tried running without it plugged in and it still crashed (this time I just let it sit there after starting the game and it crashed).

Deleting Rewired_Window_Lib.dll did create a log without "Rewired: Found Xinput1_3.dll" (log6) but there is still a crash.

I hope all this helps!
(0045984)
x4000Bughunter (administrator)
Mar 13, 2017 6:03 pm

Nuts! I was hoping that was it.

If you start it up and just leave it running while you get coffee or something, does it crash? No keyboard presses whatsoever, and no mouse clicks in the game window itself?
(0045985)
treyra (reporter)
Mar 13, 2017 6:20 pm
edited on: Mar 13, 2017 6:25 pm

Yeah, it took about a minute or so, then it just seized up.

Timing about 50 seconds. This was without any mouse movement past clicking the start button, eventually it flipped to not-responding.

On a third try 43 seconds.

(0045986)
x4000Bughunter (administrator)
Mar 13, 2017 7:43 pm

Okay, thanks -- if you don't hit the start button, does it still do this? I'm wondering if this is some sort of threading thing.

If there was a past version that didn't do this for you, do you have any idea what that version was? If not, I can make some steam beta branches for older builds to let you swap between them. Apologies for all the legwork I'm having you do -- I greatly appreciate it!
(0045987)
treyra (reporter)
Mar 13, 2017 8:38 pm

Oops, I meant the start button as in launching it from steam. Sorry for the unclear language there. So it will crash with no user input other than to initialize the program.

I believe .104 was the last version that I was able to test, and that did not have this issue. I didn't get to try any last week, but that's what finals week does to you.

No worries on the leg work. The testing is pretty fun.
(0045988)
BadgerBadger (reporter)
Mar 13, 2017 8:46 pm

I recommend putting your AI War 2 instance into a version tracking repository (SVN, git, etc) and updating it with each version. It makes it very easy to try out older versions.
(0045989)
x4000Bughunter (administrator)
Mar 14, 2017 10:51 am

Okay, in the steam betas tab for the game, there are now beta entries for 0.104, 0.106, and 0.108. Can you let us know which one(s) work for you, if any of them? That will help us narrow things down.

Regarding a tracking repo, the main problem with that is the sheer filesize. Putting the entire game into something like that would require, at present, 2.77GB. That's only going to grow -- perhaps triple, perhaps a bit more. The reason for the extreme size is that everything is tripled because of the three different OSes. You only see about a third of that in any given steam install, since by nature it's on a single OS at a time.

Anyway, I'm not aware of free repo locations that provide something of that scale. Even more to the point, that's just the size for the repo in its one-version state. As things get updated, the actual repo size would likely grow to 20-50 GB depending on how good the binary diffing is on the asset bundles. Those aren't fully deterministic, so that causes extra issues.

For us in our own internal SVN, we're checking in the raw files and not having things tripled, or all bundled up, etc. But then it's really complex to compile, not to mention it has a lot of non-public stuff. That's presently only about 2GB for this game last I looked, but that's without any of the tripling, just with the diffs and so on only being so good on binary files.

Sooo... long story short, I like using Steam's free and simple method of allowing for betas. :)
(0045990)
BadgerBadger (reporter)
Mar 14, 2017 10:55 am

I was actually trying to suggest that treyra should put their game into a repository, not Arcen. I assumed you guys were just following your own process, whatever that was.
(0045991)
x4000Bughunter (administrator)
Mar 14, 2017 10:58 am

Oh, I gotcha. Yeah, doing a local repo is easier and free; although I don't really expect people to be going that overboard to help us test. We can always provide older versions as needed, to make it easier on you guys.
(0045993)
treyra (reporter)
Mar 14, 2017 2:24 pm

Hmm... All the old builds (both Open Gl and DX 9) have the Nullreference exception: Object not set to an instance of object. I think BadgerBadger ran into that one before. I saved log files for those in case you are interested, but I think you've already seen that issue?

I know .104 worked for me in the past, as I managed to loose the game on the build and reported that there was no game over screen (which Kieth said was intentional). Perhaps I could have used a repository, but that is something I haven't really played around with before. I might give it a go if I try modding it like you have been Badger.
(0045994)
x4000Bughunter (administrator)
Mar 14, 2017 2:37 pm

If the old builds also have that, then I think what needs to happen is you delete all the contents of the steam folder for the game while being on beta 0.104, then verify the integrity of the steam file cache. I'm guessing it is reading in something it shouldn't be, I guess from a future version.

Have you made any mods or anything? If so, be sure to back those up.
(0045995)
treyra (reporter)
Mar 14, 2017 3:11 pm

I tried the clean uninstall/reinstall for .104 and I am getting the game to run now, but minus shaders, so everything is pink. It crashes pretty shortly, but that might be due to the shader issue and not the other problem. I'm going to give the other betas a try.
(0045996)
treyra (reporter)
Mar 14, 2017 3:26 pm

Good news! The DX 9 version of .106 is running smoothly. (The open GL version crashed after about a minute again, log7). I left the DX9 version open for about 2 and a half minutes with no user input and just watched the FPS counter. It dropped about 1:40 in from 420 -160 when the game windows borders changed colors, and then again to about 100 when I finally clicked in.

I've been letting it run in the background now while writing this up and it hasn't crashed yet(9 mins in, taking planet 2). I did notice it makes a pretty awful static-y sound as everything stutters whenever I drag the web browser frame around. I'll close it and get the log up (log 8). Also music has changed at least 2 times no trouble.
(0045997)
treyra (reporter)
Mar 14, 2017 3:38 pm

Okay so .108 crashed again on open GL (log 9) but once again the DX 9 version seems to be happy. And it didn't freak out if I move the browser window around at first. Strangely it started doing that after about 3 minutes, and now it is doing it intermittently about once a minute movement or no. Even stranger is the game time then races to catch up with real time after a stutter.

But the good news is after about 6 minutes of game play, no crashes here either. Again I'll but a log of this one up too. (log 10). Hope I'm not drowning you in logs.
(0045998)
x4000Bughunter (administrator)
Mar 14, 2017 3:53 pm

You're not inundating me at all -- it is super strange results, though! Overall it sounds like OpenGL is borked on your machine, and compiling with it defaulting to that causes issues for you.

I'm adding in DirectX11 support, and we'll see if that does better. It won't take anything away, but it will be a third option that's around.

The pink textures for shaders really makes no sense to me unless it was loading the wrong version of an asset bundle or something. I'm really not sure what that one was about.

The static in the background with moving around windows in your browser also sounds like some sort of wider driver issue. But it sounds like that is limited to OpenGL, so hopefully if I get this going better on the DX front for you that should cease being an issue.

Fingers crossed!
(0045999)
x4000Bughunter (administrator)
Mar 14, 2017 4:01 pm

Okay! Let's call this issue fixed, one way or the other -- it's getting very bloated now, and enough things are changing in this coming build that I'd like to have a fresh issue opened if this is still a problem in 0.112. If we still have problems in the next version, then it's probably a variant of the same thing, not quite exactly the same thing. Definitely good to link the two issues if it comes back up, though.

Thanks!

* DirectX11 is now supported on the windows builds of the game, and is the default on that platform instead of OpenGLCore.
** This should help for some people's systems that can run DX9 just fine, but which run into problems with OpenGL.
(0046000)
treyra (reporter)
Mar 14, 2017 4:15 pm

Okay thanks!
(0046001)
x4000Bughunter (administrator)
Mar 14, 2017 4:16 pm

That just released. :)
(0046002)
x4000Bughunter (administrator)
Mar 14, 2017 4:16 pm

Sorry, added note: restart steam to force it to upgrade immediately.
(0046003)
treyra (reporter)
Mar 14, 2017 5:29 pm

That did the trick!

The window stuttering thing is still there, but much less noticeable.
(0046006)
x4000Bughunter (administrator)
Mar 14, 2017 7:22 pm

Thank the maker!! :D

Issue Community Support
This issue is already marked as resolved.
If you feel that is not the case, please reopen it and explain why.
Supporters: No one explicitly supports this issue yet.
Opponents: No one explicitly opposes this issue yet.

- Issue History
Date Modified Username Field Change
Mar 11, 2017 1:46 am treyra New Issue
Mar 11, 2017 11:33 am BadgerBadger Note Added: 0045961
Mar 11, 2017 2:51 pm treyra Note Added: 0045963
Mar 11, 2017 2:59 pm treyra Note Edited: 0045963 View Revisions
Mar 13, 2017 10:30 am x4000Bughunter Note Added: 0045966
Mar 13, 2017 10:30 am x4000Bughunter Assigned To => x4000Bughunter
Mar 13, 2017 10:30 am x4000Bughunter Status new => assigned
Mar 13, 2017 3:43 pm treyra File Added: output_log.txt
Mar 13, 2017 3:46 pm treyra Note Added: 0045970
Mar 13, 2017 4:02 pm treyra Note Added: 0045971
Mar 13, 2017 4:12 pm x4000Bughunter Relationship added related to 0019041
Mar 13, 2017 4:16 pm treyra File Added: output_log2.txt
Mar 13, 2017 4:17 pm treyra File Added: Crash.png
Mar 13, 2017 4:19 pm treyra Note Added: 0045974
Mar 13, 2017 4:19 pm x4000Bughunter Note Added: 0045975
Mar 13, 2017 4:22 pm treyra Note Added: 0045977
Mar 13, 2017 4:22 pm x4000Bughunter Note Added: 0045978
Mar 13, 2017 4:37 pm treyra Note Added: 0045979
Mar 13, 2017 4:44 pm treyra Note Added: 0045980
Mar 13, 2017 4:44 pm treyra File Added: output_log3.txt
Mar 13, 2017 4:45 pm treyra File Added: output_log4.txt
Mar 13, 2017 4:45 pm treyra File Added: output_log5.txt
Mar 13, 2017 4:52 pm treyra Note Added: 0045981
Mar 13, 2017 5:00 pm x4000Bughunter Note Added: 0045982
Mar 13, 2017 5:46 pm treyra Note Added: 0045983
Mar 13, 2017 5:46 pm treyra File Added: output_log6.txt
Mar 13, 2017 6:03 pm x4000Bughunter Note Added: 0045984
Mar 13, 2017 6:20 pm treyra Note Added: 0045985
Mar 13, 2017 6:24 pm treyra Note Edited: 0045985 View Revisions
Mar 13, 2017 6:25 pm treyra Note Edited: 0045985 View Revisions
Mar 13, 2017 7:43 pm x4000Bughunter Note Added: 0045986
Mar 13, 2017 8:38 pm treyra Note Added: 0045987
Mar 13, 2017 8:46 pm BadgerBadger Note Added: 0045988
Mar 14, 2017 10:51 am x4000Bughunter Note Added: 0045989
Mar 14, 2017 10:55 am BadgerBadger Note Added: 0045990
Mar 14, 2017 10:58 am x4000Bughunter Note Added: 0045991
Mar 14, 2017 2:24 pm treyra Note Added: 0045993
Mar 14, 2017 2:37 pm x4000Bughunter Note Added: 0045994
Mar 14, 2017 3:11 pm treyra Note Added: 0045995
Mar 14, 2017 3:26 pm treyra Note Added: 0045996
Mar 14, 2017 3:27 pm treyra File Added: output_log7.txt
Mar 14, 2017 3:27 pm treyra File Added: output_log8.txt
Mar 14, 2017 3:38 pm treyra Note Added: 0045997
Mar 14, 2017 3:38 pm treyra File Added: output_log9.txt
Mar 14, 2017 3:38 pm treyra File Added: output_log10.txt
Mar 14, 2017 3:53 pm x4000Bughunter Note Added: 0045998
Mar 14, 2017 4:01 pm x4000Bughunter Note Added: 0045999
Mar 14, 2017 4:01 pm x4000Bughunter Status assigned => resolved
Mar 14, 2017 4:01 pm x4000Bughunter Fixed in Version => 0.112 Plasma, Forcefields, and DirectX11
Mar 14, 2017 4:01 pm x4000Bughunter Resolution open => fixed
Mar 14, 2017 4:15 pm treyra Note Added: 0046000
Mar 14, 2017 4:16 pm x4000Bughunter Note Added: 0046001
Mar 14, 2017 4:16 pm x4000Bughunter Note Added: 0046002
Mar 14, 2017 5:29 pm treyra Note Added: 0046003
Mar 14, 2017 7:22 pm x4000Bughunter Note Added: 0046006


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker