View Issue Details

IDProjectCategoryLast Update
0019028AI War 2[All Projects] Crash/ExceptionMar 13, 2017 12:30 pm
ReporterBadgerBadgerAssigned Tokeith.lamothe 
Severityminor 
Status resolvedResolutionfixed 
Product Version0.109 Special Forces And Modding 
Fixed in Version0.110 and 0.111 Modding Overhaul And Unity Upgrade 
Summary0019028: Unity aborts when changing galaxy type
DescriptionI started a new game on Linux. I clicked "Start New Game", then "Map Type", and then the game pauses for about 10 seconds and I see this error:

[[email protected] AIWar2]$ ./AIWar2Linux.x86_64
....
PlayerConnection initialized from /home/user/AIWar2/AIWar2Linux_Data (debug = 0)
PlayerConnection initialized network socket : 0.0.0.0 55004
Multi-casting "[IP] 192.168.1.4 [Port] 55004 [Flags] 2 [Guid] 161202516 [EditorId] 1117205967 [Version] 1048832 [Id] LinuxPlayer(192.168.1.4) [Debug] 0" to [225.0.0.222:54997]...
Started listening to [0.0.0.0:55004]
PlayerConnection already initialized - listening to [0.0.0.0:55004]
displaymanager : xrandr version warning. 1.5
client has 6 screens
displaymanager screen (0)(DisplayPort-0): 1920 x 1200
displaymanager screen (1)(HDMI-0): 2560 x 1440
Using libudev for joystick management


Importing game controller configs
Aborted (core dumped)


There's nothing in the arcen logs, and it doesn't seem to be even generating a coredump
syslog:
myComputer abrt-hook-ccpp: Process 7040 (AIWar2Linux.x86_64) of user X killed by SIGABRT - dumping core
myComputer abrt-hook-ccpp: Failed to create core_backtrace: dwfl_getthread_frames failed: No DWARF information found
TagsNo tags attached.

Activities

x4000Bughunter

Mar 9, 2017 8:49 pm

administrator   ~0045945

Any idea what map type you were clicking on? It sounds like an infinite loop.

BadgerBadger

Mar 9, 2017 8:51 pm

reporter   ~0045946

Last edited: Mar 9, 2017 8:51 pm

View 2 revisions

It was the very first one. "Clusters". This is 100% reproducible, so lemme know if you need any more debugging information.

x4000Bughunter

Mar 9, 2017 8:52 pm

administrator   ~0045947

10-4. Thanks!

BadgerBadger

Mar 9, 2017 8:54 pm

reporter   ~0045948

Last edited: Mar 9, 2017 8:56 pm

View 2 revisions

This also happens if I click on the Seed: <NUMBER> button in the same window, or if I change my starting planet

BadgerBadger

Mar 9, 2017 9:19 pm

reporter   ~0045949

This problem does not seem to reproduce on OSX. Seems linux specific.

x4000Bughunter

Mar 10, 2017 10:06 am

administrator   ~0045951

Hmm. Do you have any log files here?

~/.config/unity3d/CompanyName/ProductName/Player.log

BadgerBadger

Mar 10, 2017 10:17 am

reporter   ~0045953

Last edited: Mar 10, 2017 10:20 am

View 2 revisions

Yeah, i see a NULL exception. Uploading the logs, they are in notes.txt. The "notes" file was the wrong file, but I can't figure out how to delete it

BadgerBadger

Mar 10, 2017 10:17 am

reporter  

notes (769 bytes)
Note this game has a bit of modding done;
my Ark is extra powerful.
I spawned a bunch of ships and destroyed the enemy defenses on the first planet.
I then captured it, bumped the AI Progress up to 250 and then
spawned a wave; I conjectured that "more things" in the galaxy would
allow me to find the problem more quickly.

At 9:25, here is top output for the program (about 2 minutes after I paused)
KiB Mem : 16199336 total, 12496904 free,  1131964 used,  2570468 buff/cache
KiB Swap:  8191996 total,  8191996 free,        0 used. 14626900 avail Mem 

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND     
 3416 wdavis    20   0 4349316 399868  68896 R  75.0  2.5   3:18.98 AIWar2Linu+ 

I also saved the game at 9:28, in case that's of use
notes (769 bytes)

BadgerBadger

Mar 10, 2017 10:19 am

reporter  

notes.txt (10,212 bytes)
resizing window to 3360 x 1080
Desktop is 4480 x 1440 @ 60 Hz
World Created, Launching Server
UnityEngine.DebugLogHandler:Internal_Log(LogType, String, Object)
UnityEngine.DebugLogHandler:LogFormat(LogType, Object, String, Object[])
UnityEngine.Logger:Log(LogType, Object)
UnityEngine.Debug:Log(Object)
Arcen.Universal.ArcenDebugging:ArcenDebugLog(String, DebugLogDestination, Boolean, Verbosity) (at D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:120)
Arcen.Universal.ArcenDebugging:ArcenDebugLogSingleLine(String, Verbosity) (at D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\UtilityLibraries\ArcenDebugging.cs:104)
Arcen.AIW2.Core.Engine_AIW2:InnerDoStartNewWorldOKLogic() (at D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Engine_AIW2.cs:550)
Arcen.AIW2.External.Input_MainHandler:HandleInner(Int32, String)
Arcen.AIW2.External.bStartGame:HandleClick()
Arcen.Universal.ArcenUI_Button:OnClick(PointerEventData) (at D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Button.cs:95)
Arcen.Universal.ArcenButtonEventHandlingHooks:OnPointerClick(PointerEventData) (at D:\vclarge\AI_War_2_Ultra\ArcenUniversal\src\ArcenUI\ArcenUI_Button.cs:126)
UnityEngine.EventSystems.ExecuteEvents:Execute(IPointerClickHandler, BaseEventData) (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\ExecuteEvents.cs:52)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1) (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\ExecuteEvents.cs:269)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData) (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\InputModules\StandaloneInputModule.cs:531)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32) (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\InputModules\StandaloneInputModule.cs:430)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent() (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\InputModules\StandaloneInputModule.cs:410)
UnityEngine.EventSystems.StandaloneInputModule:Process() (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\InputModules\StandaloneInputModule.cs:184)
UnityEngine.EventSystems.EventSystem:Update() (at C:\buildslave\unity\build\Extensions\guisystem\UnityEngine.UI\EventSystem\EventSystem.cs:287)
 
(Filename: D Line: 0)

Platform assembly: /home/wdavis/AIWar2/AIWar2Linux_Data/Managed/System.Configuration.dll (this message is harmless)
Receiving unhandled NULL exception
#0  0x007fcc334d6b40 in funlockfile
#1  0x007fcc334d7100 in _Unwind_GetTextRelBase
#2  0x007fcc334d7170 in _Unwind_GetTextRelBase
#3  0x007fcc334d7330 in _Unwind_ForcedUnwind
#4  0x007fcc334d7560 in __pthread_unwind
#5  0x007fcc334d7570 in pthread_exit
#6  0x007fcc334d7580 in mono_pthread_key_for_tls
#7  0x007fcc334d7590 in mono_thread_exit
#8  0x007fcc334d75a0 in mono_method_marked_as_wrapperless
#9  0x007fcc334d77d0 in mono_amd64_throw_exception
#10 0x007fcc334d7910 in (Unknown)
#11 0x007fcc334d7920 in (Unknown)
#12 0x007fcc334d7930 in mono_set_defaults
#13 0x007fcc334d7df0 in mono_runtime_invoke
#14 0x007fcc334d7e20 in mono_thread_create
#15 0x007fcc334d7e60 in mono_pthread_key_for_tls
#16 0x007fcc334d7e80 in GC_start_blocking
#17 0x007fcc334d7f20 in start_thread
#18 0x007fcc334d7fc0 in clone
000cd957 in do_futex_wait.constprop () from /lib64/libpthread.so.0
#1  0x00007fcd000cda04 in __new_sem_wait_slow.constprop.0 () from /lib64/libpthread.so.0
#2  0x00007fcd000cdaaa in [email protected]@GLIBC_2.2.5 () from /lib64/libpthread.so.0
#3  0x00000000008a3707 in JobQueue::ProcessJobs ()
#4  0x00000000008a384a in JobQueue::WorkLoop ()
#5  0x0000000000ab8738 in Thread::RunThreadWrapper ()
#6  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#7  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 10 (Thread 0x7fcce8012700 (LWP 3657)):
#0  0x00007fccfe94a01d in poll () from /lib64/libc.so.6
#1  0x00007fccfdf29d10 in _xcb_conn_wait () from /lib64/libxcb.so.1
#2  0x00007fccfdf2bba9 in xcb_wait_for_special_event () from /lib64/libxcb.so.1
#3  0x00007fccf9834be7 in dri3_find_back () from /lib64/libGLX_mesa.so.0
#4  0x00007fccf98359f0 in loader_dri3_get_buffers () from /lib64/libGLX_mesa.so.0
#5  0x00007fccf32b18be in dri2_allocate_textures () from /usr/lib64/dri/radeonsi_dri.so
#6  0x00007fccf32ac9e4 in dri_st_framebuffer_validate () from /usr/lib64/dri/radeonsi_dri.so
#7  0x00007fccf3149db4 in st_framebuffer_validate () from /usr/lib64/dri/radeonsi_dri.so
#8  0x00007fccf314ad3c in st_manager_validate_framebuffers () from /usr/lib64/dri/radeonsi_dri.so
#9  0x00007fccf310434b in st_validate_state () from /usr/lib64/dri/radeonsi_dri.so
#10 0x00007fccf310cfd4 in st_Clear () from /usr/lib64/dri/radeonsi_dri.so
#11 0x00000000014f08c1 in ApiGLES::Clear ()
#12 0x00000000014dbcf9 in gles::ClearCurrentFramebuffer ()
#13 0x000000000149836c in GfxDeviceWorker::RunCommand ()
#14 0x000000000149d22b in GfxDeviceWorker::Run ()
#15 0x0000000001491cca in GfxDeviceWorker::RunGfxDeviceWorker ()
#16 0x0000000000ab8738 in Thread::RunThreadWrapper ()
#17 0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#18 0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 9 (Thread 0x7fcce9014700 (LWP 3656)):
#0  0x00007fcd000cb460 in [email protected]@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fccf332bc4b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fccf332baa7 in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#4  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 8 (Thread 0x7fcce9815700 (LWP 3655)):
#0  0x00007fcd000cb460 in [email protected]@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fccf332bc4b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fccf332baa7 in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#4  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 7 (Thread 0x7fccf082c700 (LWP 3654)):
#0  0x00007fcd000cb460 in [email protected]@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fccf332bc4b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fccf332baa7 in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#4  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 6 (Thread 0x7fccf102d700 (LWP 3653)):
#0  0x00007fcd000cb460 in [email protected]@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fccf332bc4b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fccf332baa7 in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#4  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 5 (Thread 0x7fccf1a35700 (LWP 3652)):
#0  0x00007fcd000cb460 in [email protected]@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fccf332bc4b in util_queue_thread_func () from /usr/lib64/dri/radeonsi_dri.so
#2  0x00007fccf332baa7 in impl_thrd_routine () from /usr/lib64/dri/radeonsi_dri.so
#3  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#4  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7fccfae7b700 (LWP 3651)):
#0  0x00007fcd000cd957 in do_futex_wait.constprop () from /lib64/libpthread.so.0
#1  0x00007fcd000cda04 in __new_sem_wait_slow.constprop.0 () from /lib64/libpthread.so.0
#2  0x00007fcd000cdaaa in [email protected]@GLIBC_2.2.5 () from /lib64/libpthread.so.0
#3  0x00000000006a11f8 in AsyncReadManagerThreaded::ThreadEntry ()
#4  0x00000000006a1b69 in AsyncReadManagerThreaded::StaticThreadEntry ()
#5  0x0000000000ab8738 in Thread::RunThreadWrapper ()
#6  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#7  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7fccfb07c700 (LWP 3650)):
#0  0x00007fcd000cd957 in do_futex_wait.constprop () from /lib64/libpthread.so.0
#1  0x00007fcd000cda04 in __new_sem_wait_slow.constprop.0 () from /lib64/libpthread.so.0
#2  0x00007fcd000cdaaa in [email protected]@GLIBC_2.2.5 () from /lib64/libpthread.so.0
#3  0x00007fccfba724a3 in mono_sem_wait () from /home/wdavis/AIWar2/AIWar2Linux_Data/Mono/x86_64/libmono.so
#4  0x00007fccfb9dcd91 in ?? () from /home/wdavis/AIWar2/AIWar2Linux_Data/Mono/x86_64/libmono.so
#5  0x00007fccfba4480e in ?? () from /home/wdavis/AIWar2/AIWar2Linux_Data/Mono/x86_64/libmono.so
#6  0x00007fccfba6a3bb in ?? () from /home/wdavis/AIWar2/AIWar2Linux_Data/Mono/x86_64/libmono.so
#7  0x00007fccfba8af06 in ?? () from /home/wdavis/AIWar2/AIWar2Linux_Data/Mono/x86_64/libmono.so
#8  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#9  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7fccfb10d700 (LWP 3649)):
#0  0x00007fcd000cb809 in [email protected]@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fccfba56f96 in ?? () from /home/wdavis/AIWar2/AIWar2Linux_Data/Mono/x86_64/libmono.so
#2  0x00007fcd000c56ca in start_thread () from /lib64/libpthread.so.0
#3  0x00007fccfe955f7f in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7fcd006dab80 (LWP 3648)):
#0  0x00007fcd000cd957 in do_futex_wait.constprop () from /lib64/libpthread.so.0
#1  0x00007fcd000cda04 in __new_sem_wait_slow.constprop.0 () from /lib64/libpthread.so.0
#2  0x00007fcd000cdaaa in [email protected]@GLIBC_2.2.5 () from /lib64/libpthread.so.0
#3  0x0000000001492439 in WaitForEvent ()
#4  0x0000000001488d98 in GfxDeviceClient::BeginFrame ()
#5  0x000000000097df01 in Forward ()
#6  0x0000000000962663 in PlayerLoop ()
#7  0x0000000000478646 in main ()

=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================


notes.txt (10,212 bytes)

x4000Bughunter

Mar 10, 2017 10:25 am

administrator   ~0045954

Got it, thanks -- I'll see what I can find out. The place where that has a nullref is extraordinarily strange. I'll see if I can duplicate it on my linux install. I'm not sure if this is a bug in the jobs system of the build of unity we're using at present; we may wind up needing to upgrade sooner than I had previously planned, not that that's a crisis.

x4000Bughunter

Mar 10, 2017 4:49 pm

administrator   ~0045956

So, I can duplicate this on my linux box, but not windows. That's not really providing me much information, though, on what is at core happening. The debug files from your machine and mine are both pretty useless, unfortunately. It happens so fast on mine that I don't think it's an infinite loop or any other logic issue. I think it's something deeper in unity.

With that in mind, the thing I'm going to try next is an upgrade to the latest patch version of unity, and we'll see if that inherently fixes it or not. The current beta has a couple of issues that make me not want to go to that one just yet, and I want to wait until Monday for a change of this magnitude just in case it causes further issues.

Either way, moving to a newer build will be a good thing in the long run, but it's enough of a hassle that I try to do it only when there's some clear case as to why. This seems to be one of them -- at the very least, hopefully a newer build will give me a more informative error.

In the meantime, I'm going to poke into the logic directly for a bit and see if I can't fix anything that way.

x4000Bughunter

Mar 10, 2017 5:16 pm

administrator   ~0045957

Interestingly, on my Surface Pro 4, it also has trouble when going into the map screen, but this time even when it first gets there at all. And it only has that trouble on OpenGLCore. It's running on 4.4, and I haven't checked lower levels of OpenGL on it. You might try one of the following command-line arguments on your linux box and see what that does, if you have time:

-force-opengl: To use the legacy OpenGL back-end
-force-glcore: To use the new OpenGL back-end. With this argument, Unity will detect all the features the platform support to run with the best OpenGL version possible and all available OpenGL extensions
-force-glcoreXY: XY can be 32, 33, 40, 41, 42, 43, 44 or 45; each number representing a specific version of OpenGL. If the platform doesn’t support a specific version of OpenGL, Unity will fallback to a supported version
-force-clamped: Request that Unity doesn’t use OpenGL extensions which guarantees that multiple platforms will execute the same code path. This is an approach to test if an issue is platform specific (a driver bug for example).

Ultimately the newer version of unity should help on that, either way, if that's what the problem is.

BadgerBadger

Mar 10, 2017 5:35 pm

reporter   ~0045958

With -force-opengl I ran it once and it actually let me change the map type before crashing. On subsequent invocations it doesn't even get to the start screen, it just crashes each time.

With -force-glcore I observed the same thing.

With force-clamped, I cycled through several planets before the game crashed (possibly I was just clicking the button faster). On subsequent invocations the game did not crash immediately, but I was unable to cycle through map types, it would crash each time.

-force-glcore32: same behaviour as the original bug
-force-glcore44: I can change from "clusters" to whatever comes next before it crashes
-force-glcore45: quite unstable, it flashes the "start" screen in a most tantalizing fashion before crashing.

For additional interest's sake, I backed up to use .108 and I still see this problem now.

Also for curiousity, after running the rest of my experiments, I retried -force-opengl and it now gives me the same behaviour as the original bug. I am officially confused.

BadgerBadger

Mar 10, 2017 5:45 pm

reporter   ~0045959

Last edited: Mar 10, 2017 5:48 pm

View 2 revisions

Other random behaviour. It seems to be affected by the level of zoom on the galaxy. If, for example, I try to change planets without ever changing the zoom level, it works, sort of; usually it lets me change a couple planets before crashing. However, if I zoom out even one notch, changing planets will immediately crash the program.

x4000Bughunter

Mar 10, 2017 5:50 pm

administrator   ~0045960

This sounds like a race condition across threads, to some extent, then. It's probably us creating or destroying something in a way that we shouldn't, but it's based around the speed at which we're doing it. And certain variants of OpenGL on linux must be more or less sensitive to it.

That's super strange -- but gives us good data, thanks!

BadgerBadger

Mar 11, 2017 4:17 pm

reporter   ~0045965

In the interests of experimentation, I tried some previous versions of the code. I can not reproduce this on .106. However, .107 and everything past it does have this instability. I just didn't notice till .109

x4000Bughunter

Mar 13, 2017 11:26 am

administrator   ~0045967

Awesome stuff, thanks for those added details. I've upgraded the game to 0.110 now, with also an underlying unity 3d upgrade, and I have a better error message now:

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
  at Arcen.AIW2.Core.World_AIW2.DoWorldStepLogic (Arcen.AIW2.Core.ArcenSimContext Context) [0x00114] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\GameState\World_AIW2.cs:204
  at Arcen.AIW2.Core.SimExecution.Execute () [0x00042] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimExecution\SimExecution.cs:25
  at Arcen.AIW2.Core.ArcenSimPlanningContext.InnerRun () [0x0002d] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:80
  at Arcen.AIW2.Core.ArcenExecutionContext.InnerRun () [0x0000d] in D:\vclarge\AI_War_2_Ultra\ArcenAIW2Core\src\Logic\Sim\SimPlanningLoop.cs:216
Thread (nil) may have been prematurely finalized
Thread (nil) may have been prematurely finalized

This one puts it in Keith's area, even though it's OS-specific (kinda-sorta). I imagine that whatever is happening there is not healthy on any OS, but linux is the one that is just completely passing out over it.

x4000Bughunter

Mar 13, 2017 12:30 pm

administrator   ~0045968

Okay! Keith got that fixed. :)

Oddly enough, this was an error on all the OSes, but it was only causing the program to die on linux. So I guess linux was our canary in this case, but the underlying problem was there in general.

I put in some code to hopefully make linux a bit less of a canary, as well, but we'll see what happens as that progresses.

Thanks for your help and patience!

Issue History

Date Modified Username Field Change
Mar 9, 2017 8:48 pm BadgerBadger New Issue
Mar 9, 2017 8:49 pm x4000Bughunter Note Added: 0045945
Mar 9, 2017 8:51 pm BadgerBadger Note Added: 0045946
Mar 9, 2017 8:51 pm BadgerBadger Note Edited: 0045946 View Revisions
Mar 9, 2017 8:52 pm x4000Bughunter Note Added: 0045947
Mar 9, 2017 8:54 pm BadgerBadger Note Added: 0045948
Mar 9, 2017 8:56 pm BadgerBadger Note Edited: 0045948 View Revisions
Mar 9, 2017 9:19 pm BadgerBadger Note Added: 0045949
Mar 10, 2017 10:06 am x4000Bughunter Note Added: 0045951
Mar 10, 2017 10:17 am BadgerBadger Note Added: 0045953
Mar 10, 2017 10:17 am BadgerBadger File Added: notes
Mar 10, 2017 10:19 am BadgerBadger File Added: notes.txt
Mar 10, 2017 10:20 am BadgerBadger Note Edited: 0045953 View Revisions
Mar 10, 2017 10:24 am x4000Bughunter Assigned To => x4000Bughunter
Mar 10, 2017 10:24 am x4000Bughunter Status new => assigned
Mar 10, 2017 10:25 am x4000Bughunter Note Added: 0045954
Mar 10, 2017 4:49 pm x4000Bughunter Note Added: 0045956
Mar 10, 2017 5:16 pm x4000Bughunter Note Added: 0045957
Mar 10, 2017 5:35 pm BadgerBadger Note Added: 0045958
Mar 10, 2017 5:45 pm BadgerBadger Note Added: 0045959
Mar 10, 2017 5:48 pm BadgerBadger Note Edited: 0045959 View Revisions
Mar 10, 2017 5:50 pm x4000Bughunter Note Added: 0045960
Mar 11, 2017 4:17 pm BadgerBadger Note Added: 0045965
Mar 13, 2017 11:26 am x4000Bughunter Note Added: 0045967
Mar 13, 2017 11:26 am x4000Bughunter Assigned To x4000Bughunter => keith.lamothe
Mar 13, 2017 12:30 pm x4000Bughunter Note Added: 0045968
Mar 13, 2017 12:30 pm x4000Bughunter Status assigned => resolved
Mar 13, 2017 12:30 pm x4000Bughunter Fixed in Version => 0.110 and 0.111 Modding Overhaul And Unity Upgrade
Mar 13, 2017 12:30 pm x4000Bughunter Resolution open => fixed